The crucial bit
[ 80%] Linking CXX executable ../bin/ccmake
cd 
/Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/work/cmake-3.11.0_build/Source
 && /Users/brad/Gentoo/usr/bin/cmake -E cmake_link_script 
CMakeFiles/ccmake.dir/link.txt --verbose=1
/Users/brad/Gentoo/usr/lib/llvm/6/bin/x86_64-apple-darwin17-clang++  
-march=native -O2 -pipe -Wl,-search_paths_first 
-Wl,-headerpad_max_install_names -Wl,-dead_strip_dylibs 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesOptionsWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesBoolWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesCacheEntryComposite.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesDummyWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesFilePathWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesForm.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesLabelWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesLongMessageForm.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesMainForm.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesPathWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesStringWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/cmCursesWidget.cxx.o 
CMakeFiles/ccmake.dir/CursesDialog/ccmake.cxx.o  -o ../bin/ccmake libCMakeLib.a 
/Users/brad/Gentoo/usr/lib/libform.dylib 
/Users/brad/Gentoo/usr/lib/libncurses.dylib kwsys/libcmsys.a 
/Users/brad/Gentoo/usr/lib/libexpat.dylib /Users/brad/Gentoo/usr/lib/libz.dylib 
/Users/brad/Gentoo/usr/lib/libarchive.dylib 
../Utilities/cmcompress/libcmcompress.a 
/Users/brad/Gentoo/usr/lib/libcurl.dylib ../Utilities/cmjsoncpp/libcmjsoncpp.a 
/Users/brad/Gentoo/usr/lib/libuv.dylib 
/Users/brad/Gentoo/usr/lib/librhash.dylib -framework CoreFoundation 
Undefined symbols for architecture x86_64:
  "_LSOpenCFURLRef", referenced from:
      cmGlobalXCodeGenerator::Open(std::__1::basic_string<char, 
std::__1::char_traits<char>, std::__1::allocator<char> > const&, 
std::__1::basic_string<char, std::__1::char_traits<char>, 
std::__1::allocator<char> > const&, bool) in 
libCMakeLib.a(cmGlobalXCodeGenerator.cxx.o)
ld: symbol(s) not found for architecture x86_64
clang-6.0: error: linker command failed with exit code 1 (use -v 
to see invocation)


> On 6/04/2018, at 20:09, Brad Macpherson <b...@teched-creations.com> wrote:
> 
> Hi,
> 
> I tried a clean bootstrap.sh on High Sierra (10.13.4), and eventually
> came up with the same:
> 
>  * Messages for package dev-util/cmake-3.11.0:
> 
>  * ERROR: dev-util/cmake-3.11.0::gentoo_prefix failed (compile phase):
>  *   emake failed
>  *
>  * If you need support, post the output of `emerge --info
> '=dev-util/cmake-3.11.0::gentoo_prefix'`,
>  * the complete build log and the output of `emerge -pqv
> '=dev-util/cmake-3.11.0::gentoo_prefix'`.
>  * The complete build log is located at
> '/Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/temp/build.log'.
>  * The ebuild environment file is located at
> '/Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/temp/environment'.
>  * Working directory:
> '/Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/work/cmake-3.11.0_build'
>  * S:
> '/Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/work/cmake-3.11.0'
> 
> Oh yeah, I thought I was almost there, and then this!  I did
>   emerge -e system
> and it failed at some point :(  Details might be found in the build log:
>   /Users/brad/Gentoo/var/tmp/portage/dev-util/cmake-3.11.0/temp/build.log
> I have no clue, really.  Please find friendly folks in #gentoo-prefix on
> irc.gentoo.org, gentoo-alt@lists.gentoo.org mailing list, or file a bug
> at bugs.gentoo.org under Gentoo/Alt, Prefix Support.
> You know, I got the feeling you just started to like me, but I guess
> that's all gone now.  I'll bother you no longer.
> 
> Trying a rerun now, will let you know how it goes; build.log and
> environment attached if they're any use.
> 
> Cheers
> 
> Brad
> 
> 
> On 04/04/2018 18:38, Fabian Groffen wrote:
>> Unfortunately not, it's a Mach-O problem.
>> 
>> On 04-04-2018 10:09:02 -0400, Anton Molyboha wrote:
>>> I have lost my access to a Mac (it used to be a work machine and I don't 
>>> work
>>> there any more) - is it something that can be debugged in a Linux host? I'd 
>>> like
>>> to give it a try.
>>> 
>>> On Wed, Apr 4, 2018 at 9:54 AM, Fabian Groffen <[1]grob...@gentoo.org> 
>>> wrote:
>>> 
>>>> I'm in the process to fix something related, but I haven't seen this
>>>> particular install_name reference problem myself yet.
>>>> On 04-04-2018 15:46:19 +0200, Johannes Schulte-Wülwer wrote:
>>>>> Thanks Anton, 
>>>>> 
>>>>> Unfortunately I have to wait for the weekend to try your solution (Don't
>>>> have
>>>>> access to the iMac before Saturday). I'll let you know if retrying a 
>>>>> couple
>>>> of
>>>>> times helps.
>>>>> 
>>>>> BR,
>>>>> 
>>>>> Johannes
>>>>> 
>>>>> 2018-03-30 16:43 GMT+02:00 Anton Molyboha
>>>> <[1][2]anton.stay.connec...@gmail.com>:
>>>>>> Hi Johannes,
>>>>>> This looks similar to bug #637470 ([2][3]https://bugs.gentoo.org/637470)
>>>> -- if it
>>>>>> is, then retrying a couple of times generally solves it.
>>>>>> Anton
>>>>>> On Wed, Mar 28, 2018 at 9:45 AM, Johannes Schulte-Wülwer
>>>>>> <[3][4]j.schultewuel...@googlemail.com> wrote:
>>>>>>> Hi, this is the last message that I get:
>>>>>>> * If you need support, post the output of `emerge --info
>>>>>>> '=dev-lang/python-2.7.14::gentoo_prefix'`,
>>>>>>>  * the complete build log and the output of `emerge -pqv
>>>>>>> '=dev-lang/python-2.7.14::gentoo_prefix'`.
>>>>>>>  * The complete build log is located at
>>>>>>> 
>>>> '/Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/temp/build.log'.
>>>>>>>  * The ebuild environment file is located at
>>>>>>> 
>>>> '/Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/temp/environment'.
>>>>>>>  * Working directory:
>>>>>>> '/Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image'
>>>>>>>  * S:
>>>>>>> 
>>>> '/Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/work/Python-2.7.14'
>>>>>>> Hmmmm, I was already afraid of this to happen.  Running
>>>>>>>   /Users/jschultewu/Gentoo/usr/bin/bash ./bootstrap-prefix.sh
>>>>>>> "/Users/jschultewu/Gentoo" stage3
>>>>>>> somewhere failed :(  Details might be found in the build log:
>>>>>>>  
>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/temp/build.log
>>>>>>> I have no clue, really.  Please find friendly folks in #gentoo-prefix on
>>>>>>> [4][5]irc.gentoo.org, [5][6]gentoo-alt@lists.gentoo.org mailing list, or
>>>> file a bug
>>>>>>> at [6][7]bugs.gentoo.org under Gentoo/Alt, Prefix Support.  This is most
>>>>>>> inconvenient, and it crushed my ego.  Sorry, I give up.
>>>>>>> Should you want to give it a try, there is
>>>>>>> /Users/jschultewu/Gentoo/stage3.log
>>>>>>> BR,
>>>>>>> Johannes
>>>>>>> 2018-03-28 15:41 GMT+02:00 Fabian Groffen <[7][8]grob...@gentoo.org>:
>>>>>>>> You mentioned you were bootstrapping, what is the exit message you got
>>>>>>>> from bootstrap-prefix.sh?
>>>>>>>> On 28-03-2018 15:34:49 +0200, Johannes Schulte-Wülwer wrote:
>>>>>>>>> Sorry, I don't know. How can I figure out?
>>>>>>>>> 
>>>>>>>>> 2018-03-28 15:11 GMT+02:00 Fabian Groffen
>>>> <[1][8][9]grob...@gentoo.org>:
>>>>>>>>>> Is this during the final emerge -e system stage?  Do you happen to
>>>> know?
>>>>>>>>>> On 28-03-2018 14:57:05 +0200, Johannes Schulte-Wülwer wrote:
>>>>>>>>>>> Hi all,
>>>>>>>>>>> 
>>>>>>>>>>> I am trying to build gentoo prefix on macOS High Sierra 10.13 and
>>>> I am
>>>>>>>>>> getting
>>>>>>>>>>> an error during python 2.7.14 build:
>>>>>>>>>>> 
>>>>>>>>>>>>>> Completed installing python-2.7.14 into
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image/
>>>>>>>>>>>  * Final size of build directory: 90480 KiB (88.3 MiB)
>>>>>>>>>>> 
>>>>>>>>>>>  * Final size of installed tree:  89472 KiB (87.3 MiB)
>>>>>>>>>>> 
>>>>>>>>>>> grep:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image/Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/include/python2.7:
>>>>>>>>>>> Is a directory
>>>>>>>>>>> 
>>>>>>>>>>> grep:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image/Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Headers:
>>>>>>>>>>> Is a directory
>>>>>>>>>>> 
>>>>>>>>>>> grep:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image/Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/lib/python2.7:
>>>>>>>>>>> Is a directory
>>>>>>>>>>> 
>>>>>>>>>>>  * prefixing shebang of
>>>> Users/jschultewu/Gentoo/etc/init.d/pydoc-2.7
>>>>>>>>>>> ecompressdir: bzip2 -9 /usr/share/man
>>>>>>>>>>> 
>>>>>>>>>>> ecompressdir: bzip2 -9 /usr/share/doc
>>>>>>>>>>> 
>>>>>>>>>>>  * QA Notice: install_name references ${D}:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image//Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Python
>>>>>>>>>>> in
>>>> /Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/bin/pythonw2.7
>>>>>>>>>>>  * QA Notice: install_name references ${D}:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image//Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Python
>>>>>>>>>>> in
>>>> /Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/bin/python2.7
>>>>>>>>>>>  * QA Notice: invalid self-reference install_name
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image//Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Python
>>>>>>>>>>> in
>>>>>>>> /Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Python
>>>>>>>>>>>  * QA Notice: install_name references ${D}:
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/var/tmp/portage/dev-lang/python-2.7.14/image//Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Python
>>>>>>>>>>> in
>>>>>>>>>>> 
>>>> /Users/jschultewu/Gentoo/usr/lib/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python
>>>>>>>>>>>  * ERROR: dev-lang/python-2.7.14::gentoo_prefix failed:
>>>>>>>>>>> 
>>>>>>>>>>>  *   invalid install_name found, your application or library will
>>>>>>>> crash at
>>>>>>>>>>> runtime
>>>>>>>>>>> 
>>>>>>>>>>>  * 
>>>>>>>>>>> 
>>>>>>>>>>>  * Call stack:
>>>>>>>>>>> 
>>>>>>>>>>>  *   misc-functions.sh, line 1299:  Called install_qa_check
>>>>>>>>>>> 
>>>>>>>>>>>  *   misc-functions.sh, line  241:  Called install_qa_check_macho
>>>>>>>>>>> 
>>>>>>>>>>>  *   misc-functions.sh, line  422:  Called die
>>>>>>>>>>> 
>>>>>>>>>>>  * The specific snippet of code:
>>>>>>>>>>> 
>>>>>>>>>>>  *    has allow_broken_install_names ${FEATURES} || \
>>>>>>>>>>> 
>>>>>>>>>>>  *    die "invalid install_name found, your application or library
>>>>>>>> will
>>>>>>>>>> crash at
>>>>>>>>>>> runtime"
>>>>>>>>>>> 
>>>>>>>>>>> Does anyone has a clue what is going wrong here?
>>>>>>>>>>> 
>>>>>>>>>>> BR,
>>>>>>>>>>> 
>>>>>>>>>>> Johannes
>>>>>>>>>>> 
>>>>>>>>>>> 
>>>>>>>>>>> read_char: errno==EILSEQ; invalid byte sequence for UTF-8:
>>>>>>>>>> --
>>>>>>>>>> Fabian Groffen
>>>>>>>>>> Gentoo on a different level
>>>>>>>>> 
>>>>>>>>> 
>>>>>>>>>   References:
>>>>>>>>>     1. mailto:[9][10]grob...@gentoo.org
>>>>>>>>> read_char: errno==EILSEQ; invalid byte sequence for UTF-8:
>>>>>>>> --
>>>>>>>> Fabian Groffen
>>>>>>>> Gentoo on a different level
>>>>> 
>>>>> 
>>>>>   References:
>>>>>     1. mailto:[11]anton.stay.connec...@gmail.com
>>>>>     2. [12]https://bugs.gentoo.org/637470
>>>>>     3. mailto:[13]j.schultewuel...@googlemail.com
>>>>>     4. [14]http://irc.gentoo.org
>>>>>     5. mailto:[15]gentoo-alt@lists.gentoo.org
>>>>>     6. [16]http://bugs.gentoo.org
>>>>>     7. mailto:[17]grob...@gentoo.org
>>>>>     8. mailto:[18]grob...@gentoo.org
>>>>>     9. mailto:[19]grob...@gentoo.org
>>>>> read_char: errno==EILSEQ; invalid byte sequence for UTF-8:
>>>> --
>>>> Fabian Groffen
>>>> Gentoo on a different level
>>> 
>>> 
>>> References:
>>>   1. mailto:grob...@gentoo.org
>>>   2. mailto:anton.stay.connec...@gmail.com
>>>   3. https://bugs.gentoo.org/637470
>>>   4. mailto:j.schultewuel...@googlemail.com
>>>   5. http://irc.gentoo.org
>>>   6. mailto:gentoo-alt@lists.gentoo.org
>>>   7. http://bugs.gentoo.org
>>>   8. mailto:grob...@gentoo.org
>>>   9. mailto:grob...@gentoo.org
>>>  10. mailto:grob...@gentoo.org
>>>  11. mailto:anton.stay.connec...@gmail.com
>>>  12. https://bugs.gentoo.org/637470
>>>  13. mailto:j.schultewuel...@googlemail.com
>>>  14. http://irc.gentoo.org
>>>  15. mailto:gentoo-alt@lists.gentoo.org
>>>  16. http://bugs.gentoo.org
>>>  17. mailto:grob...@gentoo.org
>>>  18. mailto:grob...@gentoo.org
>>>  19. mailto:grob...@gentoo.org
>>> 
>>> read_char: errno==EILSEQ; invalid byte sequence for UTF-8: 
> 
> <build.log><environment.txt>

Reply via email to