commit:     d7a1261dde29e48b7ed363731cc1db24950c23c0
Author:     Gilles Dartiguelongue <eva <AT> gentoo <DOT> org>
AuthorDate: Sat Sep 17 14:08:48 2016 +0000
Commit:     Gilles Dartiguelongue <eva <AT> gentoo <DOT> org>
CommitDate: Sat Sep 17 14:55:44 2016 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d7a1261d

net-misc/modemmanager: minor ebuild fixes

Cleanup qmi-newest handling as it was removed from 1.6. Add missing gtk-doc-am 
and version for gettext.

Package-Manager: portage-2.3.0

 net-misc/modemmanager/modemmanager-1.6.2.ebuild | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/net-misc/modemmanager/modemmanager-1.6.2.ebuild 
b/net-misc/modemmanager/modemmanager-1.6.2.ebuild
index a9cd07f..4d7003e 100644
--- a/net-misc/modemmanager/modemmanager-1.6.2.ebuild
+++ b/net-misc/modemmanager/modemmanager-1.6.2.ebuild
@@ -16,9 +16,8 @@ LICENSE="GPL-2+"
 SLOT="0/1" # subslot = dbus interface version, i.e. N in 
org.freedesktop.ModemManager${N}
 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
 
-IUSE="+introspection mbim policykit systemd +qmi qmi-newest vala"
+IUSE="+introspection mbim policykit +qmi systemd vala"
 REQUIRED_USE="
-       qmi-newest? ( qmi )
        vala? ( introspection )
 "
 
@@ -28,13 +27,14 @@ RDEPEND="
        introspection? ( >=dev-libs/gobject-introspection-0.9.6:= )
        mbim? ( >=net-libs/libmbim-1.14.0 )
        policykit? ( >=sys-auth/polkit-0.106[introspection] )
-       systemd? ( >=sys-apps/systemd-183 )
        qmi? ( >=net-libs/libqmi-1.16.0:= )
+       systemd? ( >=sys-apps/systemd-183 )
 "
 DEPEND="${RDEPEND}
        dev-util/gdbus-codegen
+       >=dev-util/gtk-doc-am-1
        >=dev-util/intltool-0.40
-       sys-devel/gettext
+       >=sys-devel/gettext-0.19.3
        virtual/pkgconfig
        vala? ( $(vala_depend) )
 "
@@ -66,7 +66,6 @@ src_configure() {
                $(use_with policykit polkit) \
                $(usex systemd --with-suspend-resume=systemd 
--with-suspend-resume=no) \
                $(use_with qmi) \
-               $(use_with qmi-newest newest-qmi-commands) \
                $(use_enable vala)
 }
 

Reply via email to