commit:     3788c2aac921eaeb031b62d68163a41197909fdb
Author:     Gilles Dartiguelongue <eva <AT> gentoo <DOT> org>
AuthorDate: Sun Sep 18 21:49:46 2016 +0000
Commit:     Gilles Dartiguelongue <eva <AT> gentoo <DOT> org>
CommitDate: Sun Sep 18 22:43:27 2016 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=3788c2aa

media-plugins/gst-plugins-libav: version bump 1.8.2 → 1.8.3

Package-Manager: portage-2.3.0

 media-plugins/gst-plugins-libav/Manifest           |  1 +
 .../gst-plugins-libav-1.8.3-ffmpeg-compat.patch    | 51 ++++++++++++++
 .../gst-plugins-libav-1.8.3.ebuild                 | 77 ++++++++++++++++++++++
 3 files changed, 129 insertions(+)

diff --git a/media-plugins/gst-plugins-libav/Manifest 
b/media-plugins/gst-plugins-libav/Manifest
index b1daa73..ef3a87a 100644
--- a/media-plugins/gst-plugins-libav/Manifest
+++ b/media-plugins/gst-plugins-libav/Manifest
@@ -1,3 +1,4 @@
 DIST gst-libav-1.4.5.tar.xz 5220508 SHA256 
605c62624604f3bb5c870844cc1f2711779cc533b004c2aa1d8c0d58557afbbc SHA512 
a2f9250a51440358d205ef160119498d52cf4944fe810e736e4561f2cdbb8dabad6220d6e4da507f013c42bea69ce72acc373982642278de0a03605bbcd4f75f
 WHIRLPOOL 
075ad91101def8ee8958eaf3051390a76efa3860a4d6796b7f5f86f9b175ca493aa3094e59b24b19c59025337683178f43346e887d7b5efe46b0f9aeadcd28d2
 DIST gst-libav-1.6.3.tar.xz 7700700 SHA256 
857b9c060a0337de38c6d26238c47352433c02eabf26c2f860c854dbc35bd4ab SHA512 
8e5fde08921937f96814b7953e142fb9affa48b22f90ed5a5895ec2f7bdfe320c28f83a93c17c93ba933266a5163ce689c3ee803e78256b3d664516dffff7d08
 WHIRLPOOL 
12070c01d74bb512a62a755d77bc558b1d29d7ffefbeafc20ee193cf7ebe9b4411f6a09784f02a83ff749853e2a5cd6140a71e00631e247dccfd0cc005db98fd
 DIST gst-libav-1.8.2.tar.xz 7982640 SHA256 
b5f3c7a27b39b5f5c2f0bfd546b0c655020faf6b38d27b64b346c43e5ebf687a SHA512 
7224bc11b640f770864568262b0e21af2282d692e115148bb621405d350aa3c56c5ee23d542aaebd3729111e293b92aeacd4863b83d2f801fb9d59171eb9a61c
 WHIRLPOOL 
8fc82f33d86b7c393408ba72d86a2ce906093e7699009edf1c954d82e3524e2a15f3ebf7e0cff863a77d757fc399cc781f377ea0d8f3bf66ae5a19dd2d1c8722
+DIST gst-libav-1.8.3.tar.xz 7958532 SHA256 
9006a05990089f7155ee0e848042f6bb24e52ab1d0a59ff8d1b5d7e33001a495 SHA512 
49aa96197cd32ad31e280870495d64cdfe4bde67507e9cb166b80d0c394b510e734befa3ff13d6fe0711be0ffa24dd0a63a77fb62af91ab776d9844059cb839d
 WHIRLPOOL 
0109f897ce7d42d21b467b42a661f02900896ea90c085f731b1c69de9c4913de36f3d48544db6fd44a5b828614947b6b9b1d851af2c5f739fbb537ac3022af88

diff --git 
a/media-plugins/gst-plugins-libav/files/gst-plugins-libav-1.8.3-ffmpeg-compat.patch
 
b/media-plugins/gst-plugins-libav/files/gst-plugins-libav-1.8.3-ffmpeg-compat.patch
new file mode 100644
index 00000000..d6c027e
--- /dev/null
+++ 
b/media-plugins/gst-plugins-libav/files/gst-plugins-libav-1.8.3-ffmpeg-compat.patch
@@ -0,0 +1,51 @@
+From f48282d442689f7559bfefd70929634a0bde3b84 Mon Sep 17 00:00:00 2001
+From: Iain Lane <i...@orangesquash.org.uk>
+Date: Fri, 2 Sep 2016 16:55:46 +0100
+Subject: [PATCH] Only use AV_CODEC_ID_WRAPPED_AVFRAME on new enough
+ libavcodecs
+
+https://bugzilla.gnome.org/show_bug.cgi?id=770753
+---
+ ext/libav/gstavviddec.c | 7 +++++--
+ ext/libav/gstavvidenc.c | 7 +++++--
+ 2 files changed, 10 insertions(+), 4 deletions(-)
+
+diff --git a/ext/libav/gstavviddec.c b/ext/libav/gstavviddec.c
+index 8aabcb1..71310ec 100644
+--- a/ext/libav/gstavviddec.c
++++ b/ext/libav/gstavviddec.c
+@@ -2044,8 +2044,11 @@ gst_ffmpegviddec_register (GstPlugin * plugin)
+         || in_plugin->id == AV_CODEC_ID_Y41P
+         || in_plugin->id == AV_CODEC_ID_012V
+         || in_plugin->id == AV_CODEC_ID_YUV4
+-        || in_plugin->id == AV_CODEC_ID_ZLIB
+-        || in_plugin->id == AV_CODEC_ID_WRAPPED_AVFRAME) {
++#if AV_VERSION_INT (LIBAVCODEC_VERSION_MAJOR, LIBAVCODEC_VERSION_MINOR, 
LIBAVCODEC_VERSION_MICRO) >= \
++        AV_VERSION_INT (57,4,0)
++        || in_plugin->id == AV_CODEC_ID_WRAPPED_AVFRAME
++#endif
++        || in_plugin->id == AV_CODEC_ID_ZLIB) {
+       goto next;
+     }
+ 
+diff --git a/ext/libav/gstavvidenc.c b/ext/libav/gstavvidenc.c
+index 9fb7f64..2ec32d8 100644
+--- a/ext/libav/gstavvidenc.c
++++ b/ext/libav/gstavvidenc.c
+@@ -966,8 +966,11 @@ gst_ffmpegvidenc_register (GstPlugin * plugin)
+         || in_plugin->id == AV_CODEC_ID_Y41P
+         || in_plugin->id == AV_CODEC_ID_012V
+         || in_plugin->id == AV_CODEC_ID_YUV4
+-        || in_plugin->id == AV_CODEC_ID_ZLIB
+-        || in_plugin->id == AV_CODEC_ID_WRAPPED_AVFRAME) {
++#if AV_VERSION_INT (LIBAVCODEC_VERSION_MAJOR, LIBAVCODEC_VERSION_MINOR, 
LIBAVCODEC_VERSION_MICRO) >= \
++        AV_VERSION_INT (57,4,0)
++        || in_plugin->id == AV_CODEC_ID_WRAPPED_AVFRAME
++#endif
++        || in_plugin->id == AV_CODEC_ID_ZLIB) {
+       goto next;
+     }
+ 
+-- 
+2.7.4
+

diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.8.3.ebuild 
b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.8.3.ebuild
new file mode 100644
index 00000000..91f7eea
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.8.3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+MY_PN="gst-libav"
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html";
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz";
+
+LICENSE="GPL-2"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 
~amd64-fbsd ~x86-fbsd"
+IUSE="libav +orc"
+
+# XXX: bzip2/lzma are automagic
+RDEPEND="
+       app-arch/bzip2
+       app-arch/xz-utils
+       >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+       >=media-libs/gstreamer-${PV}:1.0[${MULTILIB_USEDEP}]
+       >=media-libs/gst-plugins-base-${PV}:1.0[${MULTILIB_USEDEP}]
+       !libav? ( >=media-video/ffmpeg-2.8.5:0=[${MULTILIB_USEDEP}] )
+       orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+       >=dev-util/gtk-doc-am-1.12
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+       # Fix compatibility with ffmpeg-2.8, by the fine Debian folks
+       "${FILESDIR}"/${PN}-1.8.3-ffmpeg-compat.patch
+)
+
+multilib_src_configure() {
+       GST_PLUGINS_BUILD=""
+       # Upstream dropped support for system libav and won't work
+       # for preserving its compat anymore, forcing us to rely on internal
+       # ffmpeg copy if we don't want to cause unresolvable blockers for
+       # libav setups.
+       # https://bugzilla.gnome.org/show_bug.cgi?id=758183
+       # Prefer system ffmpeg for -libav
+       local myconf
+
+       if use libav; then
+               ewarn "Using internal ffmpeg copy as upstream dropped the"
+               ewarn "the support for compiling against system libav"
+               ewarn "http://bugzilla.gnome.org/show_bug.cgi?id=758183";
+       else
+               myconf="--with-system-libav"
+       fi
+
+       ECONF_SOURCE=${S} \
+       econf \
+               --disable-maintainer-mode \
+               --with-package-name="Gentoo GStreamer ebuild" \
+               --with-package-origin="https://www.gentoo.org"; \
+               --disable-fatal-warnings \
+               $(use_enable orc) \
+               ${myconf}
+}
+
+multilib_src_compile() {
+       # Don't build with -Werror
+       emake ERROR_CFLAGS=
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       prune_libtool_files --modules
+}

Reply via email to