commit:     a6d83b2f1d069fc2685ad9e348f8d4f4aaaefd5c
Author:     Anthony G. Basile <blueness <AT> gentoo <DOT> org>
AuthorDate: Tue Sep 20 09:27:06 2016 +0000
Commit:     Anthony G. Basile <blueness <AT> gentoo <DOT> org>
CommitDate: Tue Sep 20 09:27:06 2016 +0000
URL:        https://gitweb.gentoo.org/proj/musl.git/commit/?id=a6d83b2f

www-client/midori: no longer supported upstream

 www-client/midori/Manifest                         |   5 -
 .../files/midori-0.5.10-check_execinfo_h.patch     |  36 ------
 .../midori-0.5.10-fix-webkit2-build-breakage.patch |  22 ----
 www-client/midori/metadata.xml                     |  14 ---
 www-client/midori/midori-0.5.10-r99.ebuild         | 139 ---------------------
 5 files changed, 216 deletions(-)

diff --git a/www-client/midori/Manifest b/www-client/midori/Manifest
deleted file mode 100644
index e2e41d4..0000000
--- a/www-client/midori/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX midori-0.5.10-check_execinfo_h.patch 929 SHA256 
a054bbe22b1f259da2def7eebbb6595a86d0ccbd889823a619e7bb99b36d798f SHA512 
118826d3fb3a582f29064764833968d4c500aca3f7cf5d62276f57c10e69f2c40c8b0a564995d59e008b95835f9d328ea7733c1bfcac26441497bceae41e3be8
 WHIRLPOOL 
a19beb2d973d9317fc2b5b5ae3062314d8905bab7e0e0a48e043c09478207924a6e4964a9d8d53e2034f1d6021f5ff78389cd9faa6543afdfac9194211ff351e
-AUX midori-0.5.10-fix-webkit2-build-breakage.patch 970 SHA256 
64ad7d35ee95c63f39f1607b7c01646cc6b8b1781c8ce082ff51bba3c6f9a1ff SHA512 
e0454fb5478839a0b9bd35546e6f57a57e07e36a2ac370c3bcd9762d46be7b3aa7ba860beb4ce338d286cecffb796ec9af8b4704bac48f941814287b10fec9f6
 WHIRLPOOL 
cc9fa9f8ac6fd57522238a617801b0e1c27cf998e62c8f858266254ad77ab280d5a0e15d76b6b5e3c334e8a6e96ca4b34beedf17cd3d2de3f7d4f686a3090a00
-DIST midori_0.5.10_all_.tar.bz2 1379519 SHA256 
702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f SHA512 
9e615581b2029e2167d13bab3a580cf89b87da4979bb27982f2002b4ddb97e44d27ea910ee60df6479bd0dfa8cbef75217fa1956eb34b13475c99ab25b83f245
 WHIRLPOOL 
754b5d7b6851a2c0e537c6746d945f9412cf3757c559bcb07e455f555fa67bfc3e29ff08a39517359ba99bd0759252adea3d78f6281d7a07c8411f02da24fdc7
-EBUILD midori-0.5.10-r99.ebuild 3001 SHA256 
5ba751a19c9f95592aae8abead9879c31d80ec33ec52313323514236d7f12811 SHA512 
00abf6913ca66f01d3df1a92d63493a44facd65b5a00039017b943c64ac24df62543e75168235b25254fc4a102daf439e1b9dba611fc6c0942f4783055546881
 WHIRLPOOL 
f526adcdf6fdba2e8b740d91b1de6141d922ffe4709145f621963a7b6a9241cafacc3615245889178102dfdc6f12badcfbd620240ca83aa03cfc570bf843542d
-MISC metadata.xml 688 SHA256 
cb9e2a11c349c9511ccd24d69cb74ff0a85f887d2ea7e0207743d4a71f0e4e54 SHA512 
dfaa7adcf2f0db8d176961be398f8f2821c8630005564a406130b7f2ace3d7f22c482ae4b4ca5741ccfab6fa95d40635edb3da07a065b58fffdfb0e74cd55945
 WHIRLPOOL 
c065207daa59285043a5692d3a8c57733cdb81388f31006d8828f9b64cf8e50f3fb1986742320eb2812e770b8dc37cdebbb6047bedb060a50eff6254295fa703

diff --git a/www-client/midori/files/midori-0.5.10-check_execinfo_h.patch 
b/www-client/midori/files/midori-0.5.10-check_execinfo_h.patch
deleted file mode 100644
index 272d2a6..0000000
--- a/www-client/midori/files/midori-0.5.10-check_execinfo_h.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-See: https://code.launchpad.net/~midori/midori/findFileExecInfo/+merge/265222
-
-=== modified file 'CMakeLists.txt'
---- CMakeLists.txt     2015-06-18 05:03:38 +0000
-+++ CMakeLists.txt     2015-07-19 22:27:33 +0000
-@@ -68,6 +68,11 @@
-     if (SIGNAL)
-         add_definitions("-DHAVE_SIGNAL_H")
-     endif ()
-+
-+    find_file (EXEC_INFO execinfo.h)
-+    if (EXEC_INFO)
-+        set(VALAFLAGS ${VALAFLAGS} -D HAVE_EXECINFO_H)
-+    endif ()
- endif ()
- 
- find_library (X11 X11)
-@@ -101,17 +106,6 @@
-     add_definitions("-DHAVE_OSX=0")
- endif ()
- 
--# Check if execinfo.h header exists
--string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
--if (${BEGIN} GREATER 0)
--    string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
--else()
--    set(BSD 0)
--endif()
--if (UNIX AND NOT BSD AND NOT DFLY)
--    set(VALAFLAGS ${VALAFLAGS} -D HAVE_EXECINFO_H)
--endif ()
--
- find_package(PkgConfig)
- pkg_check_modules(DEPS REQUIRED
-                   libxml-2.0>=2.6
-

diff --git 
a/www-client/midori/files/midori-0.5.10-fix-webkit2-build-breakage.patch 
b/www-client/midori/files/midori-0.5.10-fix-webkit2-build-breakage.patch
deleted file mode 100644
index 3c6059c..0000000
--- a/www-client/midori/files/midori-0.5.10-fix-webkit2-build-breakage.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://launchpadlibrarian.net/204464340/0002-fix-webkit2-build-breakage.patch
-
-webkit_web_view_get_main_frame() is a webkit1 API function.
-Using it without a check breaks webkit2 builds.
-
-Signed-off-by: Gustavo Zacarias <gust...@zacarias.com.ar>
-
-diff -Nura midori-0.5.10.orig/midori/midori-view.c 
midori-0.5.10.wk2/midori/midori-view.c
---- midori-0.5.10.orig/midori/midori-view.c    2015-04-24 08:50:24.940501790 
-0300
-+++ midori-0.5.10.wk2/midori/midori-view.c     2015-04-25 07:19:21.707132362 
-0300
-@@ -1256,9 +1256,11 @@
-                                         message, error->message, NULL,
-                                         _("Try Again"), web_frame);
- 
-+#ifdef WEBKIT2
-     /* if the main frame for the whole tab has a network error, set tab error 
status */
-     if (web_frame == webkit_web_view_get_main_frame (web_view))
-         midori_tab_set_load_error (MIDORI_TAB (view), 
MIDORI_LOAD_ERROR_NETWORK);
-+#endif
- 
-     g_free (message);
-     g_free (title);

diff --git a/www-client/midori/metadata.xml b/www-client/midori/metadata.xml
deleted file mode 100644
index a04dda3..0000000
--- a/www-client/midori/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
-<pkgmetadata>
-  <maintainer type="project">
-    <email>x...@gentoo.org</email>
-    <name>XFCE Team</name>
-  </maintainer>
-  <use>
-    <flag name="deprecated">Enable GTK+-2 instead of GTK+-3 because of 
external plugins like adobe-flash</flag>
-    <flag name="granite">Enable support for the elementary library 
<pkg>dev-libs/granite</pkg></flag>
-    <flag name="zeitgeist">Add support for Zeitgeist event tracking 
system</flag>
-    <flag name="webkit2">Enable WebKit2 API that splits web content rendering 
and application UI into separate processes</flag>
-  </use>
-</pkgmetadata>

diff --git a/www-client/midori/midori-0.5.10-r99.ebuild 
b/www-client/midori/midori-0.5.10-r99.ebuild
deleted file mode 100644
index e2da754..0000000
--- a/www-client/midori/midori-0.5.10-r99.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='threads(+)'
-
-unset _live_inherits
-
-if [[ ${PV} == *9999* ]]; then
-       EGIT_REPO_URI="git://git.xfce.org/apps/${PN}"
-       _live_inherits=git-2
-else
-       KEYWORDS="~amd64 ~arm ~mips ~x86"
-       
SRC_URI="http://www.${PN}-browser.org/downloads/${PN}_${PV}_all_.tar.bz2";
-fi
-
-inherit eutils fdo-mime gnome2-utils pax-utils python-any-r1 cmake-utils vala 
${_live_inherits}
-
-DESCRIPTION="A lightweight web browser based on WebKitGTK+"
-HOMEPAGE="http://www.midori-browser.org/";
-
-LICENSE="LGPL-2.1 MIT"
-SLOT="0"
-IUSE="deprecated doc granite introspection +jit +webkit2 zeitgeist"
-
-RDEPEND="
-       >=app-crypt/gcr-3[gtk]
-       >=dev-db/sqlite-3.6.19:3
-       >=dev-libs/glib-2.32.3
-       dev-libs/libxml2
-       >=net-libs/libsoup-2.38:2.4
-       >=net-libs/libsoup-gnome-2.38:2.4
-       >=x11-libs/libnotify-0.7
-       x11-libs/libXScrnSaver
-       deprecated? (
-               >=net-libs/webkit-gtk-1.8.1:2[jit=]
-               >=x11-libs/gtk+-2.24:2
-               )
-       !deprecated? (
-               x11-libs/gtk+:3
-               webkit2? ( >=net-libs/webkit-gtk-1.11.91:3[jit=] )
-               !webkit2? ( >=net-libs/webkit-gtk-1.8.1:3[jit=] )
-               )
-       granite? ( >=dev-libs/granite-0.2 )
-       introspection? ( dev-libs/gobject-introspection:= )
-       zeitgeist? ( >=dev-libs/libzeitgeist-0.3.14 )
-"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       $(vala_depend)
-       dev-util/intltool
-       gnome-base/librsvg
-       sys-devel/gettext
-       doc? ( dev-util/gtk-doc )
-"
-REQUIRED_USE="
-       granite? ( !deprecated )
-       introspection? ( deprecated )
-       webkit2? ( !deprecated )
-"
-
-S=${WORKDIR}
-
-pkg_setup() {
-       python-any-r1_pkg_setup
-}
-
-src_unpack() {
-       if [[ ${PV} == *9999* ]]; then
-               git-2_src_unpack
-       else
-               default
-       fi
-}
-
-src_prepare() {
-       epatch "${FILESDIR}/${P}-fix-webkit2-build-breakage.patch"
-       epatch "${FILESDIR}/${P}-check_execinfo_h.patch"
-       vala_src_prepare
-       sed -i -e '/install/s:COPYING:HACKING TODO TRANSLATE:' CMakeLists.txt 
|| die
-}
-
-src_configure() {
-       strip-linguas -i po
-
-       local mycmakeargs=(
-               -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
-               $(cmake-utils_use_use doc APIDOCS)
-               $(cmake-utils_use_use introspection GIR)
-               $(cmake-utils_use_use granite)
-               $(cmake-utils_use_use zeitgeist)
-               -DVALA_EXECUTABLE="${VALAC}"
-               )
-
-       if use deprecated; then
-               mycmakeargs+=(
-                       -DUSE_GTK3=OFF
-                       -DHALF_BRO_INCOM_WEBKIT2=OFF
-                       )
-       else
-               mycmakeargs+=(
-                       -DUSE_GTK3=ON
-                       $(cmake-utils_use webkit2 HALF_BRO_INCOM_WEBKIT2)
-                       )
-       fi
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       local jit_is_enabled
-       if use deprecated; then
-               has_version 'net-libs/webkit-gtk:2[jit]' && jit_is_enabled=yes
-       else
-               has_version 'net-libs/webkit-gtk:3[jit]' && jit_is_enabled=yes
-       fi
-       [[ ${jit_is_enabled} == yes ]] && pax-mark -m "${ED}"/usr/bin/${PN} 
#480290
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
-       gnome2_icon_cache_update
-}

Reply via email to