commit:     e848283cca650833a71476ca4c50877acabe50de
Author:     Slawomir Lis <slis <AT> gentoo <DOT> org>
AuthorDate: Wed Sep 21 11:56:41 2016 +0000
Commit:     Slawek Lis <slis <AT> gentoo <DOT> org>
CommitDate: Wed Sep 21 11:57:01 2016 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e848283c

dev-python/Kivy: use opencv in version 2*

Kivy is not working with latest opencv-3.*, only opencv-2* is supported
Reported in 593798

Package-Manager: portage-2.3.0

 dev-python/Kivy/Kivy-1.9.1.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/dev-python/Kivy/Kivy-1.9.1.ebuild 
b/dev-python/Kivy/Kivy-1.9.1.ebuild
index a87428f..94dcbc9 100644
--- a/dev-python/Kivy/Kivy-1.9.1.ebuild
+++ b/dev-python/Kivy/Kivy-1.9.1.ebuild
@@ -22,7 +22,7 @@ IUSE="cairo camera doc examples garden gstreamer +sdl spell 
test"
 RDEPEND="
        dev-python/pillow[${PYTHON_USEDEP}]
        cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
-       camera? ( media-libs/opencv[${PYTHON_USEDEP}] )
+       camera? ( media-libs/opencv:0/2.4[$(python_gen_usedep 'python2_7')] )
        garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
        gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
        sdl? ( media-libs/libsdl2

Reply via email to