commit:     4040a498dacedda8e9d618b5a51ad6746fffa136
Author:     Ian Stakenvicius <axs <AT> gentoo <DOT> org>
AuthorDate: Wed Oct 12 14:13:39 2016 +0000
Commit:     Ian Stakenvicius <axs <AT> gentoo <DOT> org>
CommitDate: Wed Oct 12 14:20:11 2016 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4040a498

x11-themes/greybird: add slot to gtk+3 dependency atom

Package-Manager: portage-2.3.0

 ...{greybird-3.20.1-r1.ebuild => greybird-3.20.1-r2.ebuild} | 13 ++++++++++++-
 x11-themes/greybird/greybird-9999.ebuild                    |  2 +-
 2 files changed, 13 insertions(+), 2 deletions(-)

diff --git a/x11-themes/greybird/greybird-3.20.1-r1.ebuild 
b/x11-themes/greybird/greybird-3.20.1-r2.ebuild
similarity index 71%
rename from x11-themes/greybird/greybird-3.20.1-r1.ebuild
rename to x11-themes/greybird/greybird-3.20.1-r2.ebuild
index b8093ce..33cb11c 100644
--- a/x11-themes/greybird/greybird-3.20.1-r1.ebuild
+++ b/x11-themes/greybird/greybird-3.20.1-r2.ebuild
@@ -19,7 +19,7 @@ IUSE="ayatana gnome"
 
 RDEPEND="
        >=x11-themes/gtk-engines-murrine-0.90
-       >=x11-libs/gtk+-3.20.0
+       >=x11-libs/gtk+-3.20.0:3
 "
 DEPEND="${RDEPEND}
        dev-ruby/sass
@@ -42,3 +42,14 @@ src_install() {
        use gnome || rm -rf metacity-1
        popd > /dev/null || die
 }
+
+pkg_postinst() {
+       if ! has_version x11-themes/elementary-xfce-icon-theme ; then
+               elog "For upstream's default icon theme, please emerge"
+               elog "x11-themes/elementary-xfce-icon-theme"
+       fi
+       if ! has_version x11-themes/vanilla-dmz-xcursors ; then
+               elog "For upstream's default cursor theme, please emerge"
+               elog "x11-themes/vanilla-dmz-xcursors"
+       fi
+}

diff --git a/x11-themes/greybird/greybird-9999.ebuild 
b/x11-themes/greybird/greybird-9999.ebuild
index dd25b51..88e931a 100644
--- a/x11-themes/greybird/greybird-9999.ebuild
+++ b/x11-themes/greybird/greybird-9999.ebuild
@@ -19,7 +19,7 @@ IUSE="ayatana gnome"
 
 RDEPEND="
        >=x11-themes/gtk-engines-murrine-0.90
-       >=x11-libs/gtk+-3.20.0
+       >=x11-libs/gtk+-3.20.0:3
 "
 DEPEND="${RDEPEND}
        dev-ruby/sass

Reply via email to