commit:     e45d4241402987dbf43f86808143a0cdd823594a
Author:     Michael Palimaka <kensington <AT> gentoo <DOT> org>
AuthorDate: Wed Oct 12 17:08:49 2016 +0000
Commit:     Michael Palimaka <kensington <AT> gentoo <DOT> org>
CommitDate: Wed Oct 12 17:10:36 2016 +0000
URL:        https://gitweb.gentoo.org/proj/kde.git/commit/?id=e45d4241

kde5.eclass: drop obsolete FRAMEWORKS_MINIMAL conditional

5.26.0 is unconditionally required since 
0511d3cc56a91ab98addc442b062feb92aaba2db.

 eclass/kde5.eclass | 6 ------
 1 file changed, 6 deletions(-)

diff --git a/eclass/kde5.eclass b/eclass/kde5.eclass
index 52c432d..0d88c41 100644
--- a/eclass/kde5.eclass
+++ b/eclass/kde5.eclass
@@ -159,12 +159,6 @@ case ${KDE_AUTODEPS} in
                        esac
                fi
 
-               if [[ ${CATEGORY} = kde-plasma ]]; then
-                       if ! [[ $(get_version_component_range 2) -le 7 && 
$(get_version_component_range 3) -lt 50 ]]; then
-                               FRAMEWORKS_MINIMAL=5.26.0
-                       fi
-               fi
-
                DEPEND+=" $(add_frameworks_dep extra-cmake-modules)"
                RDEPEND+=" >=kde-frameworks/kf-env-3"
                COMMONDEPEND+=" $(add_qt_dep qtcore)"

Reply via email to