commit:     5c5fccc039975f1af92d1043ced888450277077d
Author:     Kristian Fiskerstrand <k_f <AT> gentoo <DOT> org>
AuthorDate: Tue Oct 18 20:54:17 2016 +0000
Commit:     Kristian Fiskerstrand <k_f <AT> gentoo <DOT> org>
CommitDate: Tue Oct 18 20:54:29 2016 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5c5fccc0

app-crypt/gpgme: New upstream version 1.7.1

New upstream version 1.7.1

fixes:
Gentoo-Bug: 595296

Package-Manager: portage-2.3.1

 app-crypt/gpgme/Manifest           |  1 +
 app-crypt/gpgme/gpgme-1.7.1.ebuild | 87 ++++++++++++++++++++++++++++++++++++++
 2 files changed, 88 insertions(+)

diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
index 7d9b5ad..f8e4ec8 100644
--- a/app-crypt/gpgme/Manifest
+++ b/app-crypt/gpgme/Manifest
@@ -2,3 +2,4 @@ DIST gpgme-1.5.5.tar.bz2 976383 SHA256 
0b3d3d5107680c594777aae65882a1ff6dd1ba629
 DIST gpgme-1.6.0.tar.bz2 983573 SHA256 
b09de4197ac280b102080e09eaec6211d081efff1963bf7821cf8f4f9916099d SHA512 
b7ccccc2bac246b0759c8752cadd3e77f03da39711badfc66d0f21cefab3f3b07fe1038611ad9ca1c16a8a48d7e831dcca68d83d052456a4cf794a73e287d41b
 WHIRLPOOL 
4e753156474097dba9db2905954d1754ca408066996a01cbc7266a24654eb7c2323043f40495cc3c227d8eef540eeca47de4c23bb329a2d34604d5a4d3828970
 DIST gpgme-1.7.0-build-32bit.patch 31933 SHA256 
933eb074334b3f241290e2ff11b16165a028062b543395de4592a4678656153c SHA512 
04be159ea211ed3bc921a65fb7a489e22c98c8e03dfe2457c38045bf8be335db8d2d56ab16de4bab49f62af40cd19dfd53bfb373a77db10853d011ec583c1dde
 WHIRLPOOL 
c69c7b0e8cfea89ff6490857790dec6cda06cc43d0d6ff6546c29c99c9bef3b7c4a377daf2949d9669169a35570dc9a859e9ab604c02c89c9e9768bd5347fe4c
 DIST gpgme-1.7.0.tar.bz2 1281708 SHA256 
71f55fed0f2b3eaf7a606e59772aa645ce3ffff322d361ce359951b3f755cc48 SHA512 
8c5891104bd531d555fc4c22086cfdea9f18be6885200f02e087d695d0518e311527a227f2c41e0dc1156cc0985265d0bee6c4504de7e2d2de0bc543a1036b5a
 WHIRLPOOL 
aaf60c5a30f9161bf8edb24e583e6a83e4a6e28abe7d9878d1d36b5ab34507ff2a47695dc4856c4fdad59463a5d56de1d8d35dee3315dfa54758c8445d9f706e
+DIST gpgme-1.7.1.tar.bz2 1285809 SHA256 
d0abe1449395315eac37e4e45076bbb82732cedf94210937b37776e10cdc2bb6 SHA512 
b8c2e2aa1f413748dc8b0f9f63ef5d1ddbb00dfd82f63a28b7162cf5d8af2a33f7ba29a309da5244ad6e23a561b99716d47d02956d03ece16d06af6ff77f200c
 WHIRLPOOL 
a7eea63ba23bf034c18565c171353ed01464f814d6d8cddb4047df402a2bd4830dd719cd4f7feb41038dd8871f3064d5b7e4ffaa6e5a9bf204d42618eb7b0788

diff --git a/app-crypt/gpgme/gpgme-1.7.1.ebuild 
b/app-crypt/gpgme/gpgme-1.7.1.ebuild
new file mode 100644
index 00000000..9d190a0
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.7.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+DISTUTILS_OPTIONAL=1
+
+inherit autotools distutils-r1 eutils qmake-utils
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme";
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 
~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos 
~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs cxx python qt5 test"
+
+RDEPEND="app-crypt/gnupg
+       >=dev-libs/libassuan-2.0.2
+       >=dev-libs/libgpg-error-1.11
+       qt5? (
+               dev-qt/qtcore:5
+               !kde-apps/gpgmepp:4
+               !kde-apps/kdepimlibs:4
+       )
+       python? ( ${PYTHON_DEPS} )"
+               #doc? ( app-doc/doxygen[dot] )
+DEPEND="${RDEPEND}
+       python? ( dev-lang/swig )
+       qt5? (
+               test? ( dev-qt/qttest:5 )
+       )"
+
+REQUIRED_USE="qt5? ( cxx )"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+)
+
+do_python() {
+       if use python; then
+               pushd lang/python > /dev/null || die
+               distutils-r1_src_${EBUILD_PHASE}
+               popd > /dev/null
+       fi
+}
+
+src_prepare() {
+       default
+       eautoreconf
+       do_python
+}
+
+src_configure() {
+       local languages=()
+       use common-lisp && languages+=( "cl" )
+       use cxx && languages+=( "cpp" )
+       if use qt5; then
+               languages+=( "qt" )
+               #use doc ||
+               export DOXYGEN=
+               export MOC="$(qt5_get_bindir)/moc"
+       fi
+
+       econf \
+               --includedir="${EPREFIX}/usr/include/gpgme" \
+               --enable-languages="${languages[*]}" \
+               $(use_enable static-libs static)
+
+       use python && make -C lang/python prepare
+
+       do_python
+}
+
+src_compile() {
+       default
+       do_python
+}
+
+src_install() {
+       default
+       do_python
+       prune_libtool_files
+}

Reply via email to