commit:     f8c75d70085fc8d8e856174435ece10d167bf753
Author:     Hans de Graaff <hans <AT> degraaff <DOT> org>
AuthorDate: Wed Oct 19 05:28:33 2016 +0000
Commit:     Hans de Graaff <graaff <AT> gentoo <DOT> org>
CommitDate: Wed Oct 19 05:28:33 2016 +0000
URL:        https://gitweb.gentoo.org/dev/graaff.git/commit/?id=f8c75d70

cleanup

Package-Manager: portage-2.3.0
RepoMan-Options: --force

 dev-util/reviewboard/Manifest                 |   3 -
 dev-util/reviewboard/metadata.xml             |   2 +-
 dev-util/reviewboard/reviewboard-2.5.2.ebuild | 127 --------------------------
 dev-util/reviewboard/reviewboard-2.5.3.ebuild | 127 --------------------------
 dev-util/reviewboard/reviewboard-2.5.4.ebuild | 127 --------------------------
 5 files changed, 1 insertion(+), 385 deletions(-)

diff --git a/dev-util/reviewboard/Manifest b/dev-util/reviewboard/Manifest
index 76cf3d3..426337c 100644
--- a/dev-util/reviewboard/Manifest
+++ b/dev-util/reviewboard/Manifest
@@ -1,5 +1,2 @@
-DIST ReviewBoard-2.5.2.tar.gz 12736246 SHA256 
cdd8635a73cdfd3f8ee962a2c9bf2ccad2b117768d667e0e75fa839f7244913f SHA512 
141d33fcfb1d6e45a7b19d692c044f857e484f10adad9bd18f5e9eb87ebb77c470d503851e9a7afe4deb778ed964190c06ae5b3571f16d4ce007caf1ef7479bc
 WHIRLPOOL 
2d1635d265fbfed32ccd84c2a2858d1194f808970a4d889001ab8a5d802afdb8aa2f2ee216508aa5a99dbc98b65caae2acf23e7b044132e890296ee6764ba09e
-DIST ReviewBoard-2.5.3.tar.gz 13034851 SHA256 
3508c698fd1da0369e7b4379de43cbe8d1bb369b0cef373d77455d741eacbdd9 SHA512 
b92a7d3c877eed815734308db681eba626d9523a0fd1f55abeb50cb29ffa67de6b7b69f224601dee81f92146e7351a775b95f174f5dd61ebfdab26a52559ef63
 WHIRLPOOL 
b28650bbb7235dc12bb312a3286899f6b8155a63d1ec8e832dee3573ec86bfb3e483c91dba80667eacc4a2f37cc367dadbf3bf0711e54e14df57f2792be15ae9
-DIST ReviewBoard-2.5.4.tar.gz 12750803 SHA256 
46bd233843bc1bd92a160c1852385f45d6c3436fd1a0d026db4806f4e0ff17d8 SHA512 
930a2427479c3158766c8d5c15991d283a8e5da8acd8c1a70ce30c4e295085e7538eac108260608bc0533cda6f836258e64df307935cff604ac025f87e6f2fcb
 WHIRLPOOL 
7b0b1104e55f9cd586bc4c888c91d2d8b4b33e4a53cda0a47b720c7039acf868b52aa1b81a84ed46601f80157e665af09b884c7cf4d24b9847cb832bb7bf61a7
 DIST ReviewBoard-2.5.5.tar.gz 12765349 SHA256 
539218b2fbbf4c472c163c34ec232c43d386ac3f041144d7186a18542ef06f9a SHA512 
9a4e8c5f57fe5a78715389a2af5378152dbe30f1a9566a1a2369bec43cf07a765357e8778c949796446391cea0aacd38d3bd20e0c3d3a068961a1ec37449e3f6
 WHIRLPOOL 
c520b357979f0bd1bf42aa0a6e10cb9b448ea2c572617fef697d652c1b0e6c70059932508dad70a250055a6b181dca540ea753517b2d5ad19726e2c1ed881159
 DIST ReviewBoard-2.5.6.1.tar.gz 12768789 SHA256 
415c40472efcf153c8d223ea217234b444d56816bb89b5178b2ac2dedb6268ee SHA512 
909d437c7328e9a3cec0a339e69966004f296232545a3e3d1ebd2f2591cbdea398b16fde450656b4f86fc4f3ada0e9592d56c37135f62de011ebf1d3b4fc90fd
 WHIRLPOOL 
ddd322140707af145c5d61806c69062f35b7b9cbf29c9ac6521935aa068f1fc7ba5810ab459e8dd1933bd5056418779fe7b3ac9f9522c7aa3d9c4d57423c200b

diff --git a/dev-util/reviewboard/metadata.xml 
b/dev-util/reviewboard/metadata.xml
index 033a94f..78c20cd 100644
--- a/dev-util/reviewboard/metadata.xml
+++ b/dev-util/reviewboard/metadata.xml
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
 <pkgmetadata>
-       <maintainer>
+       <maintainer type="person">
                <email>gra...@gentoo.org</email>
                <name>Hans de Graaff</name>
        </maintainer>

diff --git a/dev-util/reviewboard/reviewboard-2.5.2.ebuild 
b/dev-util/reviewboard/reviewboard-2.5.2.ebuild
deleted file mode 100644
index 40bc783..0000000
--- a/dev-util/reviewboard/reviewboard-2.5.2.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_PN="ReviewBoard"
-DESCRIPTION="A web-based code review tool that offers developers a way to 
handle code reviews"
-HOMEPAGE="http://www.reviewboard.org/";
-SRC_URI="http://downloads.reviewboard.org/releases/${MY_PN}/2.5/${MY_PN}-${PV}.tar.gz";
-KEYWORDS="~amd64 ~x86"
-IUSE="codebase doc manual rnotes test"
-
-LICENSE="MIT"
-SLOT="0"
-S=${WORKDIR}/${MY_PN}-${PV}
-
-RDEPEND=">=dev-python/django-1.6.11.1[${PYTHON_USEDEP},sqlite]
-       <dev-python/django-1.7[${PYTHON_USEDEP},sqlite]
-       >=dev-python/django-evolution-0.7.6[${PYTHON_USEDEP}]
-       <dev-python/django-evolution-0.8[${PYTHON_USEDEP}]
-       >=dev-python/django-haystack-2.3.1[${PYTHON_USEDEP}]
-       dev-python/django-multiselectfield[${PYTHON_USEDEP}]
-       >=dev-python/Djblets-0.9[${PYTHON_USEDEP}]
-       <dev-python/Djblets-0.10[${PYTHON_USEDEP}]
-       >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
-       dev-python/docutils[${PYTHON_USEDEP}]
-       >=dev-python/markdown-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/markdown-2.7[${PYTHON_USEDEP}]
-       >=dev-python/paramiko-1.12[${PYTHON_USEDEP}]
-       dev-python/pillow[${PYTHON_USEDEP}]
-       >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
-       >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
-       >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
-       dev-python/python-memcached[${PYTHON_USEDEP}]
-       >=dev-python/pytz-2012h[${PYTHON_USEDEP}]
-       dev-python/recaptcha-client[${PYTHON_USEDEP}]
-       >=dev-python/whoosh-2.6[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
-# Tests mostly access the inet and when run mostly fail
-RESTRICT=test
-
-python_prepare_all() {
-       # Running uglify is a problem right now, so skip this step. Rather
-       # have newer versions than compacted javascript.
-       sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i 
reviewboard/settings.py || die
-
-       # 
https://github.com/reviewboard/reviewboard/commit/b1b8867deb7cd857003d8abbf16e85897b0cb4bf
-       # # The version bordering of python-dateutil is long out of date and 
wrong since end of March 2012!
-       sed -e 's:==1.5:>=1.5:' -i setup.py || die
-
-       # Use newer markdown version still available
-       sed -i -e '/markdown/ s/2.4/2.6/g' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # See https://code.google.com/p/reviewboard/issues/ #3009
-       # until build of manual can find and use ROOT_URLCONF, only possible 
build path for manual
-       # requires sacrificing the resources section, all of which call on 
ROOT_URLCONF
-       local msg="Generating docs for"
-       if use doc; then
-               if use manual; then
-                       rm -rf docs/manual/webapi//2.0/resources/ || die
-                       einfo;einfo "$msg manual"
-                       DJANGO_SETTINGS_MODULE="django.conf" emake -C 
docs/manual html
-               fi
-
-               if use codebase; then
-                       pushd docs/codebase &> /dev/null
-                       ln -sf ../../contrib/internal/conf/settings_local.py .
-                       popd &> /dev/null
-                       einfo;einfo "$msg codebase"
-                       emake -C docs/codebase html
-               fi
-
-               if use rnotes; then
-                       einfo;einfo "$msg release notes"
-                       emake -C docs/releasenotes html
-               fi
-       fi
-}
-
-python_test() {
-       pushd ${PN} > /dev/null
-       ln -sf contrib/internal/conf/settings_local.py .
-       "${PYTHON}" manage.py test || die
-}
-
-python_install_all() {
-       if use doc; then
-               if use manual; then
-                       insinto /usr/share/doc/${PF}/manual
-                       doins -r docs/manual/_build/html/
-               fi
-               if use codebase; then
-                       insinto /usr/share/doc/${PF}/codebase
-                       doins -r docs/codebase/_build/html/
-               fi
-               if use rnotes; then
-                       insinto /usr/share/doc/${PF}/release_notes
-                       doins -r docs/releasenotes/_build/html/
-               fi
-       fi
-       distutils-r1_python_install_all
-}
-
-pkg_postinst() {
-       elog "You must install any VCS tool you wish ${PN} to support."
-       elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or 
dev-util/subversion."
-       elog
-       elog "Install dev-python/mysql-python for mysql support."
-       elog "Install dev-python/psycopg for postgres support."
-       elog
-       elog "For speed and responsiveness, consider installing 
net-misc/memcached"
-       elog "and dev-python/python-memcached"
-}

diff --git a/dev-util/reviewboard/reviewboard-2.5.3.ebuild 
b/dev-util/reviewboard/reviewboard-2.5.3.ebuild
deleted file mode 100644
index a4605e6..0000000
--- a/dev-util/reviewboard/reviewboard-2.5.3.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_PN="ReviewBoard"
-DESCRIPTION="A web-based code review tool that offers developers a way to 
handle code reviews"
-HOMEPAGE="http://www.reviewboard.org/";
-SRC_URI="http://downloads.reviewboard.org/releases/${MY_PN}/2.5/${MY_PN}-${PV}.tar.gz";
-KEYWORDS="~amd64 ~x86"
-IUSE="codebase doc manual rnotes test"
-
-LICENSE="MIT"
-SLOT="0"
-S=${WORKDIR}/${MY_PN}-${PV}
-
-RDEPEND=">=dev-python/django-1.6.11.1[${PYTHON_USEDEP},sqlite]
-       <dev-python/django-1.7[${PYTHON_USEDEP},sqlite]
-       >=dev-python/django-evolution-0.7.6[${PYTHON_USEDEP}]
-       <dev-python/django-evolution-0.8[${PYTHON_USEDEP}]
-       >=dev-python/django-haystack-2.3.1[${PYTHON_USEDEP}]
-       dev-python/django-multiselectfield[${PYTHON_USEDEP}]
-       >=dev-python/Djblets-0.9.1[${PYTHON_USEDEP}]
-       <dev-python/Djblets-0.10[${PYTHON_USEDEP}]
-       >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
-       dev-python/docutils[${PYTHON_USEDEP}]
-       >=dev-python/markdown-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/markdown-2.7[${PYTHON_USEDEP}]
-       >=dev-python/paramiko-1.12[${PYTHON_USEDEP}]
-       dev-python/pillow[${PYTHON_USEDEP}]
-       >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
-       >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
-       >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
-       dev-python/python-memcached[${PYTHON_USEDEP}]
-       >=dev-python/pytz-2012h[${PYTHON_USEDEP}]
-       dev-python/recaptcha-client[${PYTHON_USEDEP}]
-       >=dev-python/whoosh-2.6[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
-# Tests mostly access the inet and when run mostly fail
-RESTRICT=test
-
-python_prepare_all() {
-       # Running uglify is a problem right now, so skip this step. Rather
-       # have newer versions than compacted javascript.
-       sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i 
reviewboard/settings.py || die
-
-       # 
https://github.com/reviewboard/reviewboard/commit/b1b8867deb7cd857003d8abbf16e85897b0cb4bf
-       # # The version bordering of python-dateutil is long out of date and 
wrong since end of March 2012!
-       sed -e 's:==1.5:>=1.5:' -i setup.py || die
-
-       # Use newer markdown version still available
-       sed -i -e '/markdown/ s/2.4/2.6/g' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # See https://code.google.com/p/reviewboard/issues/ #3009
-       # until build of manual can find and use ROOT_URLCONF, only possible 
build path for manual
-       # requires sacrificing the resources section, all of which call on 
ROOT_URLCONF
-       local msg="Generating docs for"
-       if use doc; then
-               if use manual; then
-                       rm -rf docs/manual/webapi//2.0/resources/ || die
-                       einfo;einfo "$msg manual"
-                       DJANGO_SETTINGS_MODULE="django.conf" emake -C 
docs/manual html
-               fi
-
-               if use codebase; then
-                       pushd docs/codebase &> /dev/null
-                       ln -sf ../../contrib/internal/conf/settings_local.py .
-                       popd &> /dev/null
-                       einfo;einfo "$msg codebase"
-                       emake -C docs/codebase html
-               fi
-
-               if use rnotes; then
-                       einfo;einfo "$msg release notes"
-                       emake -C docs/releasenotes html
-               fi
-       fi
-}
-
-python_test() {
-       pushd ${PN} > /dev/null
-       ln -sf contrib/internal/conf/settings_local.py .
-       "${PYTHON}" manage.py test || die
-}
-
-python_install_all() {
-       if use doc; then
-               if use manual; then
-                       insinto /usr/share/doc/${PF}/manual
-                       doins -r docs/manual/_build/html/
-               fi
-               if use codebase; then
-                       insinto /usr/share/doc/${PF}/codebase
-                       doins -r docs/codebase/_build/html/
-               fi
-               if use rnotes; then
-                       insinto /usr/share/doc/${PF}/release_notes
-                       doins -r docs/releasenotes/_build/html/
-               fi
-       fi
-       distutils-r1_python_install_all
-}
-
-pkg_postinst() {
-       elog "You must install any VCS tool you wish ${PN} to support."
-       elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or 
dev-util/subversion."
-       elog
-       elog "Install dev-python/mysql-python for mysql support."
-       elog "Install dev-python/psycopg for postgres support."
-       elog
-       elog "For speed and responsiveness, consider installing 
net-misc/memcached"
-       elog "and dev-python/python-memcached"
-}

diff --git a/dev-util/reviewboard/reviewboard-2.5.4.ebuild 
b/dev-util/reviewboard/reviewboard-2.5.4.ebuild
deleted file mode 100644
index 2443492..0000000
--- a/dev-util/reviewboard/reviewboard-2.5.4.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_PN="ReviewBoard"
-DESCRIPTION="A web-based code review tool that offers developers a way to 
handle code reviews"
-HOMEPAGE="http://www.reviewboard.org/";
-SRC_URI="http://downloads.reviewboard.org/releases/${MY_PN}/2.5/${MY_PN}-${PV}.tar.gz";
-KEYWORDS="~amd64 ~x86"
-IUSE="codebase doc manual rnotes test"
-
-LICENSE="MIT"
-SLOT="0"
-S=${WORKDIR}/${MY_PN}-${PV}
-
-RDEPEND=">=dev-python/django-1.6.11.1[${PYTHON_USEDEP},sqlite]
-       <dev-python/django-1.7[${PYTHON_USEDEP},sqlite]
-       >=dev-python/django-evolution-0.7.6[${PYTHON_USEDEP}]
-       <dev-python/django-evolution-0.8[${PYTHON_USEDEP}]
-       >=dev-python/django-haystack-2.3.1[${PYTHON_USEDEP}]
-       dev-python/django-multiselectfield[${PYTHON_USEDEP}]
-       >=dev-python/Djblets-0.9.3[${PYTHON_USEDEP}]
-       <dev-python/Djblets-0.10[${PYTHON_USEDEP}]
-       >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
-       dev-python/docutils[${PYTHON_USEDEP}]
-       >=dev-python/markdown-2.6.0[${PYTHON_USEDEP}]
-       <dev-python/markdown-2.7[${PYTHON_USEDEP}]
-       >=dev-python/paramiko-1.12[${PYTHON_USEDEP}]
-       dev-python/pillow[${PYTHON_USEDEP}]
-       >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
-       >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
-       >=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
-       dev-python/python-memcached[${PYTHON_USEDEP}]
-       >=dev-python/pytz-2012h[${PYTHON_USEDEP}]
-       dev-python/recaptcha-client[${PYTHON_USEDEP}]
-       >=dev-python/whoosh-2.6[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/nose[${PYTHON_USEDEP}] )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
-# Tests mostly access the inet and when run mostly fail
-RESTRICT=test
-
-python_prepare_all() {
-       # Running uglify is a problem right now, so skip this step. Rather
-       # have newer versions than compacted javascript.
-       sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i 
reviewboard/settings.py || die
-
-       # 
https://github.com/reviewboard/reviewboard/commit/b1b8867deb7cd857003d8abbf16e85897b0cb4bf
-       # # The version bordering of python-dateutil is long out of date and 
wrong since end of March 2012!
-       sed -e 's:==1.5:>=1.5:' -i setup.py || die
-
-       # Use newer markdown version still available
-       sed -i -e '/markdown/ s/2.4/2.6/g' setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       # See https://code.google.com/p/reviewboard/issues/ #3009
-       # until build of manual can find and use ROOT_URLCONF, only possible 
build path for manual
-       # requires sacrificing the resources section, all of which call on 
ROOT_URLCONF
-       local msg="Generating docs for"
-       if use doc; then
-               if use manual; then
-                       rm -rf docs/manual/webapi//2.0/resources/ || die
-                       einfo;einfo "$msg manual"
-                       DJANGO_SETTINGS_MODULE="django.conf" emake -C 
docs/manual html
-               fi
-
-               if use codebase; then
-                       pushd docs/codebase &> /dev/null
-                       ln -sf ../../contrib/internal/conf/settings_local.py .
-                       popd &> /dev/null
-                       einfo;einfo "$msg codebase"
-                       emake -C docs/codebase html
-               fi
-
-               if use rnotes; then
-                       einfo;einfo "$msg release notes"
-                       emake -C docs/releasenotes html
-               fi
-       fi
-}
-
-python_test() {
-       pushd ${PN} > /dev/null
-       ln -sf contrib/internal/conf/settings_local.py .
-       "${PYTHON}" manage.py test || die
-}
-
-python_install_all() {
-       if use doc; then
-               if use manual; then
-                       insinto /usr/share/doc/${PF}/manual
-                       doins -r docs/manual/_build/html/
-               fi
-               if use codebase; then
-                       insinto /usr/share/doc/${PF}/codebase
-                       doins -r docs/codebase/_build/html/
-               fi
-               if use rnotes; then
-                       insinto /usr/share/doc/${PF}/release_notes
-                       doins -r docs/releasenotes/_build/html/
-               fi
-       fi
-       distutils-r1_python_install_all
-}
-
-pkg_postinst() {
-       elog "You must install any VCS tool you wish ${PN} to support."
-       elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or 
dev-util/subversion."
-       elog
-       elog "Install dev-python/mysql-python for mysql support."
-       elog "Install dev-python/psycopg for postgres support."
-       elog
-       elog "For speed and responsiveness, consider installing 
net-misc/memcached"
-       elog "and dev-python/python-memcached"
-}

Reply via email to