commit:     dd463f7e332cb7297cd92a1aed83dc2208bee585
Author:     David Seifert <soap <AT> gentoo <DOT> org>
AuthorDate: Thu Apr 20 07:26:12 2017 +0000
Commit:     David Seifert <soap <AT> gentoo <DOT> org>
CommitDate: Thu Apr 20 07:58:13 2017 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dd463f7e

app-misc/gcalcli: [QA] Add missing python metadata variables

Package-Manager: Portage-2.3.5, Repoman-2.3.2

 app-misc/gcalcli/gcalcli-3.2.ebuild   | 14 ++++++++------
 app-misc/gcalcli/gcalcli-3.3.2.ebuild | 12 +++++++-----
 2 files changed, 15 insertions(+), 11 deletions(-)

diff --git a/app-misc/gcalcli/gcalcli-3.2.ebuild 
b/app-misc/gcalcli/gcalcli-3.2.ebuild
index 4253aef6523..b0be16fdd60 100644
--- a/app-misc/gcalcli/gcalcli-3.2.ebuild
+++ b/app-misc/gcalcli/gcalcli-3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,12 +15,14 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-DEPEND=""
-RDEPEND="dev-python/python-dateutil
-                dev-python/google-api-python-client
-                dev-python/gdata
-                dev-python/vobject"
+RDEPEND="${PYTHON_DEPS}
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/google-api-python-client[${PYTHON_USEDEP}]
+       dev-python/gdata[${PYTHON_USEDEP}]
+       dev-python/vobject[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
 
 src_install() {
        dodoc -r ChangeLog README.md docs

diff --git a/app-misc/gcalcli/gcalcli-3.3.2.ebuild 
b/app-misc/gcalcli/gcalcli-3.3.2.ebuild
index 1198238ced9..b0be16fdd60 100644
--- a/app-misc/gcalcli/gcalcli-3.3.2.ebuild
+++ b/app-misc/gcalcli/gcalcli-3.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -15,11 +15,13 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
-DEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
-                dev-python/google-api-python-client[${PYTHON_USEDEP}]
-                dev-python/gdata[${PYTHON_USEDEP}]
-                dev-python/vobject[${PYTHON_USEDEP}]"
+RDEPEND="${PYTHON_DEPS}
+       dev-python/python-dateutil[${PYTHON_USEDEP}]
+       dev-python/google-api-python-client[${PYTHON_USEDEP}]
+       dev-python/gdata[${PYTHON_USEDEP}]
+       dev-python/vobject[${PYTHON_USEDEP}]"
 RDEPEND="${DEPEND}"
 
 src_install() {

Reply via email to