commit:     07b4cdad03bb2aec184892c7691389f7169bb49d
Author:     Jan Ziak <0xe2.0x9a.0x9b <AT> gmail <DOT> com>
AuthorDate: Thu Aug  3 16:34:09 2017 +0000
Commit:     Michał Górny <mgorny <AT> gentoo <DOT> org>
CommitDate: Sun Aug  6 11:15:42 2017 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=07b4cdad

app-emulation/fuse: bump to version 1.3.8

 app-emulation/fuse/Manifest          |  1 +
 app-emulation/fuse/fuse-1.3.8.ebuild | 64 ++++++++++++++++++++++++++++++++++++
 2 files changed, 65 insertions(+)

diff --git a/app-emulation/fuse/Manifest b/app-emulation/fuse/Manifest
index b6a7d1e5d2e..330540545b3 100644
--- a/app-emulation/fuse/Manifest
+++ b/app-emulation/fuse/Manifest
@@ -1 +1,2 @@
 DIST fuse-1.3.7.tar.gz 1644585 SHA256 
ba57f4b4c1a7ed398b8d85b7da14b85bd346023bed17d8d7b6ed3e0452e7b4b0 SHA512 
68a251de93a71a6ca8c107a9bd4258e6b4f5643af5dd76c0855ebfcfcaba768b932e6d0d0ab7b521ecaef50d975b86b4bfb7094e9a72ec6bf7d94911823d0886
 WHIRLPOOL 
aab8ffdfd40ebbac9f88736dff98891f0eb51e43548ceb0c4d1ccba241009304c431651ed0c034797290eb79e6ffdd97f45591dd6efb426a60f0e511f642cf0f
+DIST fuse-1.3.8.tar.gz 1645303 SHA256 
299b7efe342c6268a05e805c20427083bcec127ad36b1ebfd4ae7294978a7de1 SHA512 
e048d984bfc405e8e9801812fcf4b0b62c8bdb67eb573a815157a1f76e4c752303c919dc62b351db25c156b944c4b1b6d28595f8ce86390221039852baf13aa6
 WHIRLPOOL 
a1dec25d878e49c11a4d69b59cce594a4a0ee075ad7b758eaa9afda9dfc6cbb2f6fded96938c4ca8473416f7f741cf3d4314fcf015aaacdb87b69387378a1ed0

diff --git a/app-emulation/fuse/fuse-1.3.8.ebuild 
b/app-emulation/fuse/fuse-1.3.8.ebuild
new file mode 100644
index 00000000000..9c2d6dfb79a
--- /dev/null
+++ b/app-emulation/fuse/fuse-1.3.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Free Unix Spectrum Emulator by Philip Kendall"
+HOMEPAGE="http://fuse-emulator.sourceforge.net";
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa ao fbcon gpm gtk joystick memlimit png sdl svga X xml"
+
+# Only one UI back-end can be enabled at a time
+REQUIRED_USE="^^ ( X fbcon gtk sdl svga )"
+
+RDEPEND=">=app-emulation/libspectrum-1.3.5
+       dev-libs/glib:2
+       X? ( x11-libs/libX11
+               x11-libs/libXext )
+       alsa? ( media-libs/alsa-lib )
+       ao? ( media-libs/libao )
+       gpm? ( sys-libs/gpm )
+       gtk? ( x11-libs/gtk+:3 )
+       joystick? ( media-libs/libjsw )
+       sdl? ( media-libs/libsdl )
+       svga? ( media-libs/svgalib )
+       png? ( media-libs/libpng:0= sys-libs/zlib )
+       xml? ( dev-libs/libxml2:2 )"
+DEPEND="${RDEPEND}
+       fbcon? ( virtual/linux-sources )
+       dev-lang/perl
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README THANKS )
+
+src_configure() {
+       local guiflag
+
+       if use gtk; then
+               guiflag=""
+       elif use sdl; then
+               guiflag="--with-sdl"
+       elif use X; then
+               guiflag="--without-gtk"
+       elif use svga; then
+               guiflag="--with-svgalib"
+       elif use fbcon; then
+               guiflag="--with-fb"
+       fi
+
+       econf \
+               --without-win32 \
+               ${guiflag} \
+               $(use_with gpm) \
+               $(use_with alsa) \
+               $(use_with ao libao) \
+               $(use_with joystick) \
+               $(use_enable joystick ui-joystick) \
+               $(use_with xml libxml2) \
+               $(use_with png ) \
+               $(use_enable memlimit smallmem)
+}

Reply via email to