commit:     2348ec2b634435ce5d2dffeb428df6caab97e32f
Author:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
AuthorDate: Sun Aug  6 12:40:01 2017 +0000
Commit:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
CommitDate: Sun Aug  6 12:40:34 2017 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2348ec2b

app-office/libreoffice: Drop obsolete checks

Gentoo-bug: 625372

Package-Manager: Portage-2.3.6, Repoman-2.3.1

 app-office/libreoffice/libreoffice-5.3.4.2.ebuild | 17 -----------------
 1 file changed, 17 deletions(-)

diff --git a/app-office/libreoffice/libreoffice-5.3.4.2.ebuild 
b/app-office/libreoffice/libreoffice-5.3.4.2.ebuild
index 2fca4af8309..c16e3878181 100644
--- a/app-office/libreoffice/libreoffice-5.3.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.3.4.2.ebuild
@@ -267,23 +267,6 @@ pkg_pretend() {
                        CHECKREQS_DISK_BUILD="6G"
                fi
                check-reqs_pkg_pretend
-
-               if ! $(tc-is-clang) && { [[ $(gcc-major-version) -lt 4 ]] ||
-                               [[ $(gcc-major-version) -eq 4 && 
$(gcc-minor-version) -lt 7 ]]; } then
-                       eerror "Compilation with gcc older than 4.7 is not 
supported"
-                       die "Too old gcc found."
-               fi
-       fi
-
-       # Ensure pg version but we have to be sure the pg is installed (first
-       # install on clean system)
-       if use postgres && has_version dev-db/postgresql; then
-                local pgslot=$(postgresql-config show)
-                if [[ ${pgslot//.} -lt 90 ]] ; then
-                       eerror "PostgreSQL slot must be set to 9.0 or higher."
-                       eerror "    postgresql-config set 9.0"
-                       die "PostgreSQL slot is not set to 9.0 or higher."
-                fi
        fi
 }
 

Reply via email to