commit:     216e7ef6531d5fe8c611fa7dae0011f0fc73c906
Author:     Ian Stakenvicius <axs <AT> gentoo <DOT> org>
AuthorDate: Fri Aug 11 15:25:52 2017 +0000
Commit:     Ian Stakenvicius <axs <AT> gentoo <DOT> org>
CommitDate: Fri Aug 11 21:23:02 2017 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=216e7ef6

sys-libs/tevent-0.9.33: prevent bundling of talloc

If sys-libs/talloc is too old or is missing, tevent would build its
own bundled copy.  This commit prevents that from happening, causing
a configuration error instead.

This commit also addresses the configuration issue that hard requires
pytalloc-util even when python is disabled (which was buried behind
the bundling issue)

Package-Manager: Portage-2.3.6, Repoman-2.3.1

 sys-libs/tevent/files/talloc-disable-python.patch | 34 +++++++++++++++++++++++
 sys-libs/tevent/tevent-0.9.33.ebuild              |  6 ++++
 2 files changed, 40 insertions(+)

diff --git a/sys-libs/tevent/files/talloc-disable-python.patch 
b/sys-libs/tevent/files/talloc-disable-python.patch
new file mode 100644
index 00000000000..6ef45eb37fb
--- /dev/null
+++ b/sys-libs/tevent/files/talloc-disable-python.patch
@@ -0,0 +1,34 @@
+--- a/lib/talloc/wscript       2017-04-28 04:57:26.000000000 -0400
++++ b/lib/talloc/wscript       2017-07-05 14:30:42.700580464 -0400
+@@ -74,19 +74,22 @@
+                                      implied_deps='replace'):
+             conf.define('USING_SYSTEM_TALLOC', 1)
+ 
+-        using_system_pytalloc_util = True
+-        if not conf.CHECK_BUNDLED_SYSTEM_PKG('pytalloc-util', 
minversion=VERSION,
+-                                             implied_deps='talloc replace'):
++        if conf.env.disable_python:
+             using_system_pytalloc_util = False
+-
+-        # We need to get a pytalloc-util for all the python versions
+-        # we are building for
+-        if conf.env['EXTRA_PYTHON']:
+-            name = 'pytalloc-util' + 
conf.all_envs['extrapython']['PYTHON_SO_ABI_FLAG']
+-            if not conf.CHECK_BUNDLED_SYSTEM_PKG(name, minversion=VERSION,
++        else:
++            using_system_pytalloc_util = True
++            if not conf.CHECK_BUNDLED_SYSTEM_PKG('pytalloc-util', 
minversion=VERSION,
+                                                  implied_deps='talloc 
replace'):
+                 using_system_pytalloc_util = False
+ 
++            # We need to get a pytalloc-util for all the python versions
++            # we are building for
++            if conf.env['EXTRA_PYTHON']:
++                name = 'pytalloc-util' + 
conf.all_envs['extrapython']['PYTHON_SO_ABI_FLAG']
++                if not conf.CHECK_BUNDLED_SYSTEM_PKG(name, minversion=VERSION,
++                                                     implied_deps='talloc 
replace'):
++                    using_system_pytalloc_util = False
++
+         if using_system_pytalloc_util:
+             conf.define('USING_SYSTEM_PYTALLOC_UTIL', 1)
+ 

diff --git a/sys-libs/tevent/tevent-0.9.33.ebuild 
b/sys-libs/tevent/tevent-0.9.33.ebuild
index c454b5e965e..fc46807e4d1 100644
--- a/sys-libs/tevent/tevent-0.9.33.ebuild
+++ b/sys-libs/tevent/tevent-0.9.33.ebuild
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
 # build system does not work with python3
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+PATCHES=(
+       "${FILESDIR}"/talloc-disable-python.patch
+)
+
 WAF_BINARY="${S}/buildtools/bin/waf"
 
 pkg_setup() {
@@ -39,6 +43,8 @@ src_prepare() {
 
 multilib_src_configure() {
        waf-utils_src_configure \
+               --bundled-libraries=NONE \
+               --builtin-libraries=NONE \
                $(multilib_native_usex python '' '--disable-python')
 }
 

Reply via email to