commit:     0dba7297ff8329a32385468d55de263db58aa2fb
Author:     Michał Górny <mgorny <AT> gentoo <DOT> org>
AuthorDate: Sat Aug 12 21:17:26 2017 +0000
Commit:     Michał Górny <mgorny <AT> gentoo <DOT> org>
CommitDate: Sat Aug 12 21:21:31 2017 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0dba7297

dev-libs/libclc: Use llvm.eclass to obtain correct llvm-config path

Use the newly-introduced llvm.eclass API to obtain the correct path
for the newest LLVM slot including clang, to fix the issue when
first-level 'clang' on PATH comes from a compiler wrapper such
as ccache.

Bug: https://bugs.gentoo.org/624034

 dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild | 17 +++++++++++------
 1 file changed, 11 insertions(+), 6 deletions(-)

diff --git a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild 
b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
index c0ac06980cb..39ad522a7e7 100644
--- a/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
+++ b/dev-libs/libclc/libclc-0.2.0_pre20170118.ebuild
@@ -15,7 +15,7 @@ else
        GIT_ECLASS="vcs-snapshot"
 fi
 
-inherit python-any-r1 toolchain-funcs ${GIT_ECLASS}
+inherit llvm python-any-r1 toolchain-funcs ${GIT_ECLASS}
 
 DESCRIPTION="OpenCL C library"
 HOMEPAGE="http://libclc.llvm.org/";
@@ -38,14 +38,19 @@ RDEPEND="
 DEPEND="${RDEPEND}
        ${PYTHON_DEPS}"
 
-src_configure() {
-       # we need to find llvm with matching clang version, so look for
-       # clang first, and then use llvm-config from the same location
-       local clang_path=$(type -P clang) || die
+llvm_check_deps() {
+       has_version "sys-devel/clang:${LLVM_SLOT}"
+}
 
+pkg_setup() {
+       # we do not need llvm_pkg_setup
+       python-any-r1_pkg_setup
+}
+
+src_configure() {
        ./configure.py \
                --with-cxx-compiler="$(tc-getCXX)" \
-               --with-llvm-config="${clang_path%/*}/llvm-config" \
+               --with-llvm-config="$(get_llvm_prefix)/bin/llvm-config" \
                --prefix="${EPREFIX}/usr" || die
 }
 

Reply via email to