commit:     f0a4e20bc5d8873cc6ef6c6aa51afeed5afc71b1
Author:     Hans de Graaff <graaff <AT> gentoo <DOT> org>
AuthorDate: Fri Feb  2 16:22:22 2018 +0000
Commit:     Hans de Graaff <graaff <AT> gentoo <DOT> org>
CommitDate: Fri Feb  2 16:41:11 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f0a4e20b

dev-ruby/bundler-audit: cleanup

Package-Manager: Portage-2.3.19, Repoman-2.3.6

 dev-ruby/bundler-audit/Manifest                   |  1 -
 dev-ruby/bundler-audit/bundler-audit-0.5.0.ebuild | 44 -----------------------
 2 files changed, 45 deletions(-)

diff --git a/dev-ruby/bundler-audit/Manifest b/dev-ruby/bundler-audit/Manifest
index 4aae2afc5c2..00d3d7a2249 100644
--- a/dev-ruby/bundler-audit/Manifest
+++ b/dev-ruby/bundler-audit/Manifest
@@ -1,2 +1 @@
-DIST bundler-audit-0.5.0.gem 99328 BLAKE2B 
729c94090b4fb84db936efdc648b29a4fda9955f481e73b69f9a489ee9b3c0dc565a0889f93c003cf43124ba46bf470a0db7ac32a5802caf5662d1fb6e62b8f2
 SHA512 
c618912f7d22b1a60dfeeaf8a278abccc3c0ec8d8dd2ea5988a0b04d6992015decf852dd507e7acd3abd19c8a62ac21f099a49aecfe04e3499a76879afb63fb7
 DIST bundler-audit-0.6.0.gem 108544 BLAKE2B 
2014f3f2cad0a4305a0b1ef3a7ed0c76e2bb6a6c609568f2823e499c19d844bf41eccac3c6f8efeb51ebc938ea888164256fe41eb0d770e5eef5f3b00a837ecd
 SHA512 
28213df41bba20b41b7398a2ac8f2086c5d2b80a7b31340a29b6e7c3818337f11e486284b14f000c590aaea6bb541222c4c5b71421e36a0e0a7c02e0feec9d7a

diff --git a/dev-ruby/bundler-audit/bundler-audit-0.5.0.ebuild 
b/dev-ruby/bundler-audit/bundler-audit-0.5.0.ebuild
deleted file mode 100644
index 9d79d27dedf..00000000000
--- a/dev-ruby/bundler-audit/bundler-audit-0.5.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Provides patch-level verification for Bundled apps"
-HOMEPAGE="https://github.com/rubysec/bundler-audit";
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux 
~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris 
~x86-solaris"
-IUSE="test"
-
-#tests are trying to download AND have some odd failures
-#rspec ./spec/database_spec.rb:113 # Bundler::Audit::Database#size should eq 
323
-#rspec ./spec/database_spec.rb:117 # Bundler::Audit::Database#advisories 
should return a list of all advisories.
-RESTRICT=test
-
-ruby_add_rdepend "
-       >=dev-ruby/thor-0.18:0
-       >=dev-ruby/bundler-1.2:0
-"
-
-all_ruby_prepare() {
-       sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
-
-       # Avoid specs that require network access via 'bundle install'
-       rm spec/{integration,scanner}_spec.rb || die
-
-       # Avoid specs that only work when the source is a git repository
-       sed -i -e '/describe "path"/,/^  end/ s:^:#:' \
-               -e '/describe "update!"/,/^  end/ s:^:#:' \
-               spec/database_spec.rb || die
-}

Reply via email to