commit:     18602efd3de03bd491dcf492bd3cea8f3fa0992d
Author:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
AuthorDate: Fri Feb  9 14:12:25 2018 +0000
Commit:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
CommitDate: Fri Feb  9 14:12:25 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=18602efd

dev-libs/mongo-c-driver: Restrict tests for x86

Tests require a local mongodb instance. However, dev-db/mongodb upstream
doesn't support x86 anymore [Bug 646016] so we are restricting tests.

Bug: https://bugs.gentoo.org/646016
Closes: https://bugs.gentoo.org/645994
Package-Manager: Portage-2.3.24, Repoman-2.3.6

 dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild 
b/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild
index 179b8e0a175..256c3356f43 100644
--- a/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-1.8.2.ebuild
@@ -23,6 +23,10 @@ RDEPEND="app-arch/snappy:=
 DEPEND="${RDEPEND}
        test? ( dev-db/mongodb )"
 
+# No tests on x86 because tests require dev-db/mongodb which don't support
+# x86 anymore (bug #645994)
+RESTRICT="x86? ( test )"
+
 src_prepare() {
        # remove bundled libs
        rm -rv src/{libbson,zlib*} || die

Reply via email to