commit:     88fc306fb88e417d4bf0e8828df233a368c4abea
Author:     Nils Freydank <holgersson <AT> posteo <DOT> de>
AuthorDate: Tue Feb 13 15:34:52 2018 +0000
Commit:     Michał Górny <mgorny <AT> gentoo <DOT> org>
CommitDate: Tue Feb 13 16:00:51 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=88fc306f

games-fps/urbanterror: Version bump to 4.3.2_p20180211.

Package-Manager: Portage-2.3.24, Repoman-2.3.6

 games-fps/urbanterror/Manifest                     |   1 +
 .../urbanterror/urbanterror-4.3.2_p20180211.ebuild | 166 +++++++++++++++++++++
 2 files changed, 167 insertions(+)

diff --git a/games-fps/urbanterror/Manifest b/games-fps/urbanterror/Manifest
index e00fb4d8e24..624b5bf0267 100644
--- a/games-fps/urbanterror/Manifest
+++ b/games-fps/urbanterror/Manifest
@@ -1 +1,2 @@
 DIST urbanterror-4.3.2_p20180206.tar.gz 10071986 BLAKE2B 
b809793f8bc1d878a97d882f60eef80124cff63ca5754f9178cdf9067acc2c6b52478362b8799c7b3718484d1a680ca932df8d97ebb34e35fc90eb2ae17582d6
 SHA512 
e4fcc53f9a7b8db1f5bc069acce5265db7009acc0588b29fff2a2b19b05d09f42cdb2c3f1811920221c75b6d3fc5f2e67fbb0f8476ee50644d8db9dd4f0b7c63
+DIST urbanterror-4.3.2_p20180211.tar.gz 10071334 BLAKE2B 
43bdbb59c7f4d7a02e87035d446d4e9dc91a2b8d2299afb97b09aa91f4062b732a71e9d624058d947dc5005f911b60f5ad7242b75b96d7e6fe750a01bc4a5494
 SHA512 
f55052f3fe5984af7d75aad95dc0673398839f8f79ed9d2a74865072f700712c9968c51e13e8e12d5b4c6b508a0a51b830d8c0afa159b88dba8200f7854f3da6

diff --git a/games-fps/urbanterror/urbanterror-4.3.2_p20180211.ebuild 
b/games-fps/urbanterror/urbanterror-4.3.2_p20180211.ebuild
new file mode 100644
index 00000000000..d96a973d082
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.3.2_p20180211.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit eapi7-ver flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://urbanterror.info https://github.com/mickael9/ioq3";
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/mickael9/ioq3.git";
+       EGIT_BRANCH="urt"
+else
+       COMMIT_ID="41425855eba78b31dde895116c4db2e8ce77a2b8"
+       SRC_URI="https://github.com/mickael9/ioq3/archive/${COMMIT_ID}.tar.gz 
-> ${P}.tar.gz"
+       S="${WORKDIR}/ioq3-${COMMIT_ID}"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+altgamma +client +curl debug mumble openal +opus server +skeetshootmod 
voip vorbis"
+REQUIRED_USE=" || ( client server )"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.3-fix-build_system.patch )
+RDEPEND="
+       client? (
+               media-libs/libsdl2:=[X,sound,joystick,opengl,video]
+               mumble? ( media-sound/mumble:= )
+               openal? ( media-libs/openal:= )
+               opus? ( media-libs/opusfile:= )
+               vorbis? (
+                       media-libs/libogg:=
+                       media-libs/libvorbis:=
+               )
+       )
+       curl? ( net-misc/curl )
+       ~games-fps/urbanterror-data-4.3.2
+       sys-libs/zlib:=[minizip]
+       virtual/jpeg:0
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+       if use client; then
+               if ! use openal && ! use opus && ! use vorbis; then
+                       ewarn
+                       ewarn "No sound implementation selected. Enable 
'openal', 'opus' or 'vorbis' USE flag to get sound!"
+               fi
+       fi
+}
+
+src_configure() {
+       default
+
+       tc-export CC
+}
+
+src_compile() {
+       # Workaround for used zlib macro, which got renamed in Gentoo
+       # wrt bug #449510
+       append-cppflags "-DOF=_Z_OF"
+
+       local my_arch=$(usex amd64 "x86_64" "i386")
+
+       emake \
+               ARCH=${my_arch} \
+               DEFAULT_BASEDIR="/usr/share/urbanterror" \
+               BUILD_CLIENT=$(usex "client" 1 0) \
+               BUILD_SERVER=$(usex "server" 1 0) \
+               BUILD_BASEGAME=1 \
+               BUILD_MISSIONPACK=0 \
+               BUILD_GAME_SO=0 \
+               BUILD_GAME_QVM=0 \
+               BUILD_STANDALONE=1 \
+               SERVERBIN="Quake3-UrT-Ded" \
+               CLIENTBIN="Quake3-UrT" \
+               USE_RENDERER_DLOPEN=0 \
+               USE_YACC=0 \
+               BASEGAME="q3ut4"\
+               BASEGAME_CFLAGS="${CFLAGS}" \
+               USE_OPENAL=$(usex "openal" 1 0) \
+               USE_OPENAL_DLOPEN=$(usex "openal" 1 0) \
+               USE_CURL=$(usex "curl" 1 0) \
+               USE_CURL_DLOPEN=$(usex "curl" 1 0) \
+               USE_CODEC_VORBIS=$(usex "vorbis" 1 0) \
+               USE_CODEC_OPUS=$(usex "opus" 1 0) \
+               USE_MUMBLE=$(usex "mumble" 1 0) \
+               USE_SKEETMOD=$(usex "skeetshootmod" 1 0) \
+               USE_VOIP=$(usex "mumble" 1 0) \
+               USE_INTERNAL_LIBS=0 \
+               USE_LOCAL_HEADERS=0 \
+               USE_ALTGAMMA=$(usex "altgamma" 1 0)
+}
+
+src_install() {
+       local my_arch=$(usex amd64 "x86_64" "i386")
+       # docs from ioq3, not from UrbanTerror ZIP file
+       dodoc ChangeLog README.md README.ioq3.md md4-readme.txt
+
+       if use client; then
+               newbin build/$(usex debug "debug" 
"release")-linux-${my_arch}/Quake3-UrT.${my_arch} ${PN}
+               # Shooter as defined in 
https://specifications.freedesktop.org/menu-spec/latest/apas02.html
+               make_desktop_entry ${PN} "UrbanTerror" ${PN}
+       fi
+
+       if use server && ! use client; then
+               # dedicated server only
+               newbin build/$(usex debug "debug" 
"release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-ded
+       fi
+}
+
+pkg_postinst() {
+       use client && xdg_desktop_database_update
+
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               # This is a new installation
+               if use openal; then
+                       elog ""
+                       elog "You might need to set:"
+                       elog "  seta s_useopenal \"1\""
+                       elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to 
work."
+               fi
+
+               if use altgamma; then
+                       elog ""
+                       elog "You might need to set:"
+                       elog "  seta r_altgamma \"1\""
+                       elog "in your ~/.q3a/q3ut4/q3config.cfg for altgamma to 
work."
+                       elog "Be aware that altgamme works on a global scale, 
so external"
+                       elog "applications like redshift can cause trouble. 
Disabling"
+                       elog "these while playing is a usable workaround."
+               fi
+
+               if ! use altgamma; then
+                       elog ""
+                       elog "If you are using a modesetting graphics driver 
you might"
+                       elog "consider setting USE=\"altgamma\"."
+                       elog "For details take a look at:"
+                       elog 
"https://bugs.freedesktop.org/show_bug.cgi?id=27222";
+               fi
+
+               if ! use client; then
+                       elog ""
+                       elog "You disabled client support. You won't be able to 
connect"
+                       elog "to any servers and play. If you want to do so, 
enable"
+                       elog "USE=\"client\"."
+               fi
+       fi
+
+       if ver_test -ge 4.3.2_p20171105; then
+               # Yippee, new features!
+               if use skeetshootmod; then
+                       elog ""
+                       elog "You might need to set:"
+                       elog "  seta sv_skeetshoot \"1\""
+                       elog "in your ~/.q3a/q3ut4/q3config.cfg to use the 
skeetshoot mod."
+               fi
+       fi
+}
+
+pkg_postrm() {
+       use client && xdg_desktop_database_update
+}

Reply via email to