commit:     649521b6086fd4dbb096a0af8a67b433557dd532
Author:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
AuthorDate: Sat Mar  3 01:34:48 2018 +0000
Commit:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
CommitDate: Sat Mar  3 02:07:16 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=649521b6

dev-python/ws4py: Bump to v0.5.1

Package-Manager: Portage-2.3.24, Repoman-2.3.6

 dev-python/ws4py/Manifest                                  |  1 +
 dev-python/ws4py/{ws4py-9999.ebuild => ws4py-0.5.1.ebuild} | 10 +++++-----
 dev-python/ws4py/ws4py-9999.ebuild                         | 10 +++++-----
 3 files changed, 11 insertions(+), 10 deletions(-)

diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
index 3af3e8f45fd..73f87f82749 100644
--- a/dev-python/ws4py/Manifest
+++ b/dev-python/ws4py/Manifest
@@ -1 +1,2 @@
 DIST ws4py-0.3.4.tar.gz 65467 BLAKE2B 
c51e338f3c65e100b55e83cd7b09fb8e4eafec3adc118a2744ea4aabc54c91efacda94cb3018550049d617b6759198cfbdb4497a024c597de942abe9e5517ab6
 SHA512 
32cd2eb9df7367e2bf42e354766a0ca407715a863be6b51b7701ec6e0537a2ecf7c2a59423f56ae093855b075c30a4065c7f7efe3b0227915639223b9ba7a55f
+DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 
31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c
 SHA512 
4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11

diff --git a/dev-python/ws4py/ws4py-9999.ebuild 
b/dev-python/ws4py/ws4py-0.5.1.ebuild
similarity index 88%
copy from dev-python/ws4py/ws4py-9999.ebuild
copy to dev-python/ws4py/ws4py-0.5.1.ebuild
index 757d4a7a3ea..c1c647c9a5e 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-0.5.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 # We could depend on dev-python/cherrypy when USE=server, but
@@ -6,17 +6,17 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git";
-       inherit git-2
+       inherit git-3
 else
        inherit vcs-snapshot
-       
SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> 
${P}.tar.gz"
+       
SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz 
-> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 fi
 

diff --git a/dev-python/ws4py/ws4py-9999.ebuild 
b/dev-python/ws4py/ws4py-9999.ebuild
index 757d4a7a3ea..74386cac1ba 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 # We could depend on dev-python/cherrypy when USE=server, but
@@ -6,17 +6,17 @@
 # Same for www-servers/tornado and USE=client ... so why not???
 # pypy is viable but better with a cutdown set of deps
 
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
 PYTHON_REQ_USE="threads?"
 
 inherit distutils-r1
 if [[ ${PV} == "9999" ]] ; then
        EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git";
-       inherit git-2
+       inherit git-r3
 else
        inherit vcs-snapshot
-       
SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> 
${P}.tar.gz"
+       
SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz 
-> ${P}.tar.gz"
        KEYWORDS="~amd64 ~arm ~x86"
 fi
 

Reply via email to