commit:     eb15e09323f2edc038491a68305e56867208c13a
Author:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
AuthorDate: Sat Mar  3 01:19:37 2018 +0000
Commit:     Thomas Deutschmann <whissi <AT> gentoo <DOT> org>
CommitDate: Sat Mar  3 02:07:13 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=eb15e093

net-misc/gns3-server: Bump to v2.1.3

Bug: https://bugs.gentoo.org/641840
Package-Manager: Portage-2.3.24, Repoman-2.3.6
RepoMan-Options: --force

 net-misc/gns3-server/Manifest                 |  1 +
 net-misc/gns3-server/gns3-server-2.1.3.ebuild | 52 +++++++++++++++++++++++++++
 2 files changed, 53 insertions(+)

diff --git a/net-misc/gns3-server/Manifest b/net-misc/gns3-server/Manifest
index cbff3aa3059..15cc02e90af 100644
--- a/net-misc/gns3-server/Manifest
+++ b/net-misc/gns3-server/Manifest
@@ -1,3 +1,4 @@
 DIST gns3-server-1.5.2.tar.gz 844649 BLAKE2B 
4c798351a3a51c9ff375235342c66a3ac32475d0e19f953f9e4f3ea2a1dda88838a42c583c7ce2681b20b1efe3505d3051a90a7918a858d8e6d9ad0dce92e900
 SHA512 
4a8beb69b2cbd6771a68d9e2877099e2103f2ca8140806ad06ba1ad7dbac6f02fca71b660871dd5af5940ecf02f0809127a1f0ff44845962aec4b0c57f1dd329
 DIST gns3-server-1.5.3.1.tar.gz 847598 BLAKE2B 
9a025150cea08830f39e63d4ff79897643bc846d4ccab4b9e3d37f8fa9b3de26296a30d3b93c38fdbb4e927653978e0aa4f1f4d5200b176f102f4c550bc7edd9
 SHA512 
79e8b2546d8239d78fcf621fe8e88c0ddc10bea2e216225ca1f48ebd4d0e307cebc81e63ded2e36cca50917d518d52d8619eed5a84b39123c3ce56f3a6606fd9
 DIST gns3-server-2.0.3.tar.gz 1468528 BLAKE2B 
fac026020563386553841e98c8f056cc270b17a7896481fb268b1633a3166737a3be111b9cf7f38dacb85ee2e8bc371fa32490e4a3fe07e708b01c57af1d79c0
 SHA512 
a9927e414f6fc6558cecabd006f9d123752b0b6e5b88408a53a6d1f195d22047ffdc3e4ccc6e132d04135c434174aa4b58f29deae9e952f83ccc678037f25b8a
+DIST gns3-server-2.1.3.tar.gz 1658657 BLAKE2B 
4ce83aceff8f70f93032b2baafb0dd5c94062b8c431a73b9a83401266ae77f18a4e318651ecd05b789b71c512fc3549d0d1fb95b26fe1fdd23b2953b3367f04c
 SHA512 
df6a98943f893f3d10c16b2a4242869a1407adad56e6c127e6525fe49acefbac9329bf76bc2b16904997985843fdb2b94d03c58f658034ec44763e6d69f7ddaf

diff --git a/net-misc/gns3-server/gns3-server-2.1.3.ebuild 
b/net-misc/gns3-server/gns3-server-2.1.3.ebuild
new file mode 100644
index 00000000000..11fbd6e25e4
--- /dev/null
+++ b/net-misc/gns3-server/gns3-server-2.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="GNS3 server to asynchronously manage emulators"
+HOMEPAGE="http://www.gns3.net/";
+SRC_URI="https://github.com/GNS3/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND=">=app-emulation/dynamips-0.2.12
+               >=dev-python/aiohttp-2.2.0[${PYTHON_USEDEP}]
+               >=dev-python/aiohttp-cors-0.5.3[${PYTHON_USEDEP}]
+               >=dev-python/docker-py-1.4.0[${PYTHON_USEDEP}]
+               >=dev-python/netifaces-0.8-r2[${PYTHON_USEDEP}]
+               >=dev-python/jinja-2.7.3[${PYTHON_USEDEP}]
+               >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+               >=dev-python/libcloud-0.14.1[${PYTHON_USEDEP}]
+               >=dev-python/raven-5.23.0[${PYTHON_USEDEP}]
+               >=dev-python/psutil-3.0.0[${PYTHON_USEDEP}]
+               >=dev-python/pyzmq-14.3.1[${PYTHON_USEDEP}]
+               >=dev-python/python-zipstream-1.1.4[${PYTHON_USEDEP}]
+               >=www-servers/tornado-3.1.1[${PYTHON_USEDEP}]
+               >=dev-python/typing-3.5.3.0[${PYTHON_USEDEP}]
+               >=dev-python/yarl-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       default
+
+       # Package installs 'tests' package which is forbidden
+       rm -rf tests || die
+}
+
+pkg_postinst() {
+       ewarn "net-misc/gns3-server has several optional packages that must be 
merged manually for additional functionality."
+       ewarn ""
+       ewarn "The following is a list of packages that can be added:"
+       ewarn "app-emulation/qemu, app-emulation/virtualbox"
+       ewarn "app-emulation/docker and net-analyzer/wireshark"
+       ewarn ""
+       ewarn "The following packages are currently unsupported:"
+       ewarn "iouyap and vpcs"
+}

Reply via email to