commit:     7830567acab1a2646b5774afb426d459ee0bc745
Author:     Michał Górny <mgorny <AT> gentoo <DOT> org>
AuthorDate: Sat Mar 10 08:03:33 2018 +0000
Commit:     Michał Górny <mgorny <AT> gentoo <DOT> org>
CommitDate: Sat Mar 10 08:21:39 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7830567a

xfce-extra/xfce4-indicator-plugin: Bump to 2.3.4

 xfce-extra/xfce4-indicator-plugin/Manifest         |  1 +
 .../xfce4-indicator-plugin-2.3.4.ebuild            | 51 ++++++++++++++++++++++
 2 files changed, 52 insertions(+)

diff --git a/xfce-extra/xfce4-indicator-plugin/Manifest 
b/xfce-extra/xfce4-indicator-plugin/Manifest
index fc19112ce80..d4ebe44dde8 100644
--- a/xfce-extra/xfce4-indicator-plugin/Manifest
+++ b/xfce-extra/xfce4-indicator-plugin/Manifest
@@ -1 +1,2 @@
 DIST xfce4-indicator-plugin-2.3.3.tar.bz2 380735 BLAKE2B 
d218c88e9b7cf862c2638f8ad6f9ec1a11797c3689d938e6a16ccea79622fb60f4b1273cf721bd72e8e26c99b1258743ecda52bbf3b52ed7c31ae052a49c2aed
 SHA512 
d220ee625d10c857f2d65c52e8d561d8ff8448e8707161baf3ef8a1365fb5306d29c480f56edf5ead091fb3078ab0ebcb25088c676ad280e5c93208e36b95c20
+DIST xfce4-indicator-plugin-2.3.4.tar.bz2 406991 BLAKE2B 
3d499f9f923e9cc51b25e2bed3dc6dfb6d4413c90d0a1afeacd14e0d1f33c9f9d5bdd6bdeb03a3e61bef0c3ec8cb1d1c766d89d921aaf9610bc797dc99a12219
 SHA512 
b1fd065c8221ae91d95b540411317cd67bb9b26d46c7cfe85ec90d7ccdcd11e7b8832008c8b6fb5c257e0b1a08360f00ad9da5520108024cc36c63d865ffdca6

diff --git 
a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild 
b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild
new file mode 100644
index 00000000000..4e41cded266
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin";
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+       >=x11-libs/gtk+-3.18:3=
+       x11-libs/libX11:=
+       >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.11:=
+       >=xfce-base/xfce4-panel-4.11:=
+       >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_configure() {
+       local myconf=(
+               # libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+               --disable-ido
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_desktop_database_update
+}

Reply via email to