commit:     05fb7f5eb4908941e81559aacac3c6797263c43b
Author:     Martin Mokrejs <mmokrejs <AT> fold <DOT> natur <DOT> cuni <DOT> cz>
AuthorDate: Fri Apr  6 23:22:14 2018 +0000
Commit:     Martin Mokrejs <mmokrejs <AT> fold <DOT> natur <DOT> cuni <DOT> cz>
CommitDate: Fri Apr  6 23:22:14 2018 +0000
URL:        https://gitweb.gentoo.org/proj/sci.git/commit/?id=05fb7f5e

sci-libs/tensorflow: version bump

The ebuild does not compile for me still, it needs more work.

Credits: Rok Kralj
Closes: https://github.com/gentoo/sci/issues/857
Package-Manager: Portage-2.3.27, Repoman-2.3.9

 sci-libs/tensorflow/tensorflow-1.5.0.ebuild | 19 +++++++++++--
 sci-libs/tensorflow/tensorflow-1.7.0.ebuild | 43 +++++++++++++++++++++++++++++
 2 files changed, 60 insertions(+), 2 deletions(-)

diff --git a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild 
b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
index b2e2e596a..0dae0c1d0 100644
--- a/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
+++ b/sci-libs/tensorflow/tensorflow-1.5.0.ebuild
@@ -17,12 +17,27 @@ SLOT="0"
 KEYWORDS=""
 IUSE="cuda mpi"
 
+# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
+# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
+# version.
+# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
+# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
+# version.
 DEPEND="dev-util/bazel
        dev-python/wheel
        dev-python/numpy
        dev-libs/protobuf-c
-       cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
+       cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 
)
        mpi? ( virtual/mpi )"
 RDEPEND="${DEPEND}"
 
-# TODO: seems it also support some MPI implementation
+# TODO: seems it also supports some MPI implementation
+
+src_configure(){
+       # there is no setup.py but there is configure
+       # https://www.tensorflow.org/install/install_sources
+       # https://www.tensorflow.org/install/install_linux#InstallingNativePip
+       #
+       # usage: configure.py [-h] [--workspace WORKSPACE]
+       ./configure || die
+}

diff --git a/sci-libs/tensorflow/tensorflow-1.7.0.ebuild 
b/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
new file mode 100644
index 000000000..0dae0c1d0
--- /dev/null
+++ b/sci-libs/tensorflow/tensorflow-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Library for numerical computation using data flow graphs"
+HOMEPAGE="https://www.tensorflow.org
+       https://github.com/tensorflow/tensorflow";
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="cuda mpi"
+
+# TensorFlow 1.7 may be the last time we support Cuda versions below 8.0.
+# Starting with TensorFlow 1.8 release, 8.0 will be the minimum supported
+# version.
+# TensorFlow 1.7 may be the last time we support cuDNN versions below 6.0.
+# Starting with TensorFlow 1.8 release, 6.0 will be the minimum supported
+# version.
+DEPEND="dev-util/bazel
+       dev-python/wheel
+       dev-python/numpy
+       dev-libs/protobuf-c
+       cuda? ( >=dev-util/nvidia-cuda-toolkit-7.0[profiler] >=dev-libs/cudnn-3 
)
+       mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# TODO: seems it also supports some MPI implementation
+
+src_configure(){
+       # there is no setup.py but there is configure
+       # https://www.tensorflow.org/install/install_sources
+       # https://www.tensorflow.org/install/install_linux#InstallingNativePip
+       #
+       # usage: configure.py [-h] [--workspace WORKSPACE]
+       ./configure || die
+}

Reply via email to