commit:     835e2f7cc9c59688ae198f0a72787aaecc061766
Author:     Aaron Bauman <bman <AT> gentoo <DOT> org>
AuthorDate: Mon Apr  9 00:01:13 2018 +0000
Commit:     Aaron Bauman <bman <AT> gentoo <DOT> org>
CommitDate: Mon Apr  9 00:02:50 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=835e2f7c

app-emulation/xen-pvgrub: drop vulnerable

Bug: https://bugs.gentoo.org/641566
Package-Manager: Portage-2.3.28, Repoman-2.3.9

 app-emulation/xen-pvgrub/Manifest                  |   2 -
 .../xen-pvgrub/xen-pvgrub-4.8.2-r1.ebuild          | 161 ---------------------
 app-emulation/xen-pvgrub/xen-pvgrub-4.9.0.ebuild   | 161 ---------------------
 3 files changed, 324 deletions(-)

diff --git a/app-emulation/xen-pvgrub/Manifest 
b/app-emulation/xen-pvgrub/Manifest
index f09628f9db0..f9ce9279173 100644
--- a/app-emulation/xen-pvgrub/Manifest
+++ b/app-emulation/xen-pvgrub/Manifest
@@ -3,7 +3,5 @@ DIST lwip-1.3.0.tar.gz 398933 BLAKE2B 
3567a593eec3d247213daaaab57d9456c9cae50329
 DIST newlib-1.16.0.tar.gz 12024353 BLAKE2B 
26d3308148fb99baf8ad02eee4cc699cfac690100ea63aaa4be03b86d12dade238478342514bd083cbc3d27964ac42eb8dae3873fdac5ff2c593fc4fb39b2309
 SHA512 
40eb96bbc6736a16b6399e0cdb73e853d0d90b685c967e77899183446664d64570277a633fdafdefc351b46ce210a99115769a1d9f47ac749d7e82837d4d1ac3
 DIST pciutils-2.2.9.tar.bz2 212265 BLAKE2B 
014b664e90c64e7255c9e21fc25a2cc60d57f47ce282fc0331a0481a460b237783bd3774dd0689e1596d4a0be0d2889faad904da01a6f02147464bce1d1b1bc0
 SHA512 
2b3d98d027e46d8c08037366dde6f0781ca03c610ef2b380984639e4ef39899ed8d8b8e4cd9c9dc54df101279b95879bd66bfd4d04ad07fef41e847ea7ae32b5
 DIST polarssl-1.1.4-gpl.tgz 611340 BLAKE2B 
613da06dda9e4b86db5a4d616a0a0afee98c907c3c6b352eed3d9e500fc5739e62eb4f6fc32ff02579c6a6de9bd49fcd2c8bd8b2d158a5050cbaa82118d61ef0
 SHA512 
88da614e4d3f4409c4fd3bb3e44c7587ba051e3fed4e33d526069a67e8180212e1ea22da984656f50e290049f60ddca65383e5983c0f8884f648d71f698303ad
-DIST xen-4.8.2.tar.gz 22522336 BLAKE2B 
2c9da971622b4e52fe78fa029107bb1c5f945a63605406493df607c410c6f2a8c2cdb38b1eb30c1bc1c8bc6e5620efad977c3ba55e04c579c01d51f0104afcce
 SHA512 
7805531f73d23ecfff3439770e62d387f4254a444875670d53a0a739323e5d4d8f8fcc478f8936ee1ae8aff3e0229549e47c01c606365a8ce060dd5c503e87da
-DIST xen-4.9.0.tar.gz 23361741 BLAKE2B 
1cfebb791ca5e51eda9b86a5d98e0883fab1554f5ac805fc065916fbbd3695e6b0f11ca75935a8f973735cc8dd83e38fe4a670d8489010be865be49d8fc1a341
 SHA512 
97f8075c49ef9ec0adbe95106c0cff4f9379578fd568777697565476c3fd948335d72ddcacf8be65fd9db219c0a35dcdc007f355f7e5874dd950fd4c0a0f966f
 DIST xen-4.9.1.tar.gz 23368303 BLAKE2B 
4cfddb351c9a4aa08227138dc1afa921f3d1880048f897428226da38eff9470cd81ae9896f174583048dad0ba8d5c1426df58b029115ba1623366d1980630c0d
 SHA512 
9d22f0aa5dcd01a1c105d17c14bce570cc597e884ddb9b4a46b80a72f647625b76ae5213cede423d0458c14e1906983595a9269bb6e6ff2e9e7e4dea840f4274
 DIST zlib-1.2.3.tar.gz 496597 BLAKE2B 
603020b70cd52b83e48bde420b86e2acfd29d69bf7476eecbeeb07d1b8bcab703d2cbd3eab77772990bddb8c268f13594592ce985798d49e2d6ba25104d49f22
 SHA512 
021b958fcd0d346c4ba761bcf0cc40f3522de6186cf5a0a6ea34a70504ce9622b1c2626fce40675bc8282cf5f5ade18473656abc38050f72f5d6480507a2106e

diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.8.2-r1.ebuild 
b/app-emulation/xen-pvgrub/xen-pvgrub-4.8.2-r1.ebuild
deleted file mode 100644
index 78a162cc1c8..00000000000
--- a/app-emulation/xen-pvgrub/xen-pvgrub-4.8.2-r1.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='xml,threads'
-
-inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
-
-XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles";
-LIBPCI_URL=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-GRUB_URL=mirror://gnu-alpha/grub
-
-UPSTREAM_VER=
-[[ -n ${UPSTREAM_VER} ]] && \
-       
UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz";
-
-SRC_URI="
-               
https://downloads.xenproject.org/release/xen/${PV}/xen-${PV}.tar.gz
-               $GRUB_URL/grub-0.97.tar.gz
-               $XEN_EXTFILES_URL/zlib-1.2.3.tar.gz
-               $LIBPCI_URL/pciutils-2.2.9.tar.bz2
-               $XEN_EXTFILES_URL/lwip-1.3.0.tar.gz
-               $XEN_EXTFILES_URL/newlib/newlib-1.16.0.tar.gz
-               $XEN_EXTFILES_URL/polarssl-1.1.4-gpl.tgz
-               ${UPSTREAM_PATCHSET_URI}"
-
-S="${WORKDIR}/xen-${PV}"
-
-DESCRIPTION="allows to boot Xen domU kernels from a menu.lst laying inside 
guest filesystem"
-HOMEPAGE="https://www.xenproject.org";
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="custom-cflags"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="sys-devel/gettext
-       sys-devel/bin86
-       sys-apps/texinfo
-       x11-libs/pixman"
-
-RDEPEND="${PYTHON_DEPS}
-       >=app-emulation/xen-tools-${PV}"
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-retar-externals() {
-       # Purely to unclutter src_prepare
-       local set="grub-0.97.tar.gz lwip-1.3.0.tar.gz newlib-1.16.0.tar.gz 
polarssl-1.1.4-gpl.tgz zlib-1.2.3.tar.gz"
-
-       # epatch can't patch in $WORKDIR, requires a sed; Bug #455194. 
Patchable, but sed informative
-       sed -e s':AR=${AR-"ar rc"}:AR=${AR-"ar"}:' \
-               -i "${WORKDIR}"/zlib-1.2.3/configure
-       sed -e 's:^AR=ar rc:AR=ar:' \
-               -e s':$(AR) $@:$(AR) rc $@:' \
-               -i "${WORKDIR}"/zlib-1.2.3/{Makefile,Makefile.in}
-       einfo "zlib Makefile edited"
-
-       cd "${WORKDIR}"
-       tar czp zlib-1.2.3 -f zlib-1.2.3.tar.gz
-       tar czp grub-0.97 -f grub-0.97.tar.gz
-       tar czp lwip -f lwip-1.3.0.tar.gz
-       tar czp newlib-1.16.0 -f newlib-1.16.0.tar.gz
-       tar czp polarssl-1.1.4 -f polarssl-1.1.4-gpl.tgz
-       mv $set "${S}"/stubdom/
-       einfo "tarballs moved to source"
-}
-
-src_prepare() {
-       # Upstream's patchset
-       if [[ -n ${UPSTREAM_VER} ]]; then
-               einfo "Try to apply Xen Upstream patch set"
-               EPATCH_SUFFIX="patch" \
-               EPATCH_FORCE="yes" \
-               EPATCH_OPTS="-p1" \
-                       epatch "${WORKDIR}"/patches-upstream
-       fi
-
-       # if the user *really* wants to use their own custom-cflags, let them
-       if use custom-cflags; then
-               einfo "User wants their own CFLAGS - removing defaults"
-               # try and remove all the default custom-cflags
-               find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk 
-exec sed \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 
's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 
's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-                       -i {} \;
-       fi
-
-       # Patch the unmergeable newlib, fix most of the leftover gcc QA issues
-       cp "${FILESDIR}"/newlib-implicits.patch stubdom || die
-
-       # Patch stubdom/Makefile to patch insource newlib & prevent internal 
downloading
-       epatch "${FILESDIR}"/${PN/-pvgrub/}-4.3-externals.patch
-
-       # fix jobserver in Makefile
-       epatch "${FILESDIR}"/${PN}-4.8-jserver.patch
-
-       #Substitute for internal downloading. pciutils copied only due to the 
only .bz2
-       cp "${DISTDIR}"/pciutils-2.2.9.tar.bz2 ./stubdom/ || die "pciutils not 
copied to stubdom"
-       retar-externals || die "re-tar procedure failed"
-
-       default
-}
-
-src_configure() {
-       local myconf="--prefix=${PREFIX}/usr \
-               --libdir=${PREFIX}/usr/$(get_libdir) \
-               --libexecdir=${PREFIX}/usr/libexec \
-               --disable-werror \
-               --disable-xen"
-
-       econf ${myconf}
-}
-
-src_compile() {
-       use custom-cflags || unset CFLAGS
-       if test-flag-CC -fno-strict-overflow; then
-               append-flags -fno-strict-overflow
-       fi
-
-       emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" -C 
tools/include
-
-       if use x86; then
-               emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
-               XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
-       elif use amd64; then
-               emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
-               XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub
-               if has_multilib_profile; then
-                       multilib_toolchain_setup x86
-                       emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
-                       XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
-               fi
-       fi
-}
-
-src_install() {
-       if use x86; then
-               emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom 
install-grub
-       fi
-       if use amd64; then
-               emake XEN_TARGET_ARCH="x86_64" DESTDIR="${D}" -C stubdom 
install-grub
-               if has_multilib_profile; then
-                       emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C 
stubdom install-grub
-               fi
-       fi
-}
-
-pkg_postinst() {
-       elog "Official Xen Guide and the offical wiki page:"
-       elog "https://wiki.gentoo.org/wiki/Xen";
-       elog "https://wiki.xen.org/wiki/Main_Page";
-}

diff --git a/app-emulation/xen-pvgrub/xen-pvgrub-4.9.0.ebuild 
b/app-emulation/xen-pvgrub/xen-pvgrub-4.9.0.ebuild
deleted file mode 100644
index 4f3af9d4100..00000000000
--- a/app-emulation/xen-pvgrub/xen-pvgrub-4.9.0.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE='xml,threads'
-
-inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
-
-XEN_EXTFILES_URL="http://xenbits.xensource.com/xen-extfiles";
-LIBPCI_URL=ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-GRUB_URL=mirror://gnu-alpha/grub
-
-UPSTREAM_VER=
-[[ -n ${UPSTREAM_VER} ]] && \
-       
UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P/-tools/}-upstream-patches-${UPSTREAM_VER}.tar.xz";
-
-SRC_URI="
-               
https://downloads.xenproject.org/release/xen/${PV}/xen-${PV}.tar.gz
-               $GRUB_URL/grub-0.97.tar.gz
-               $XEN_EXTFILES_URL/zlib-1.2.3.tar.gz
-               $LIBPCI_URL/pciutils-2.2.9.tar.bz2
-               $XEN_EXTFILES_URL/lwip-1.3.0.tar.gz
-               $XEN_EXTFILES_URL/newlib/newlib-1.16.0.tar.gz
-               $XEN_EXTFILES_URL/polarssl-1.1.4-gpl.tgz
-               ${UPSTREAM_PATCHSET_URI}"
-
-S="${WORKDIR}/xen-${PV}"
-
-DESCRIPTION="allows to boot Xen domU kernels from a menu.lst laying inside 
guest filesystem"
-HOMEPAGE="https://www.xenproject.org";
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="custom-cflags"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="sys-devel/gettext
-       sys-devel/bin86
-       sys-apps/texinfo
-       x11-libs/pixman"
-
-RDEPEND="${PYTHON_DEPS}
-       >=app-emulation/xen-tools-${PV}"
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-retar-externals() {
-       # Purely to unclutter src_prepare
-       local set="grub-0.97.tar.gz lwip-1.3.0.tar.gz newlib-1.16.0.tar.gz 
polarssl-1.1.4-gpl.tgz zlib-1.2.3.tar.gz"
-
-       # epatch can't patch in $WORKDIR, requires a sed; Bug #455194. 
Patchable, but sed informative
-       sed -e s':AR=${AR-"ar rc"}:AR=${AR-"ar"}:' \
-               -i "${WORKDIR}"/zlib-1.2.3/configure
-       sed -e 's:^AR=ar rc:AR=ar:' \
-               -e s':$(AR) $@:$(AR) rc $@:' \
-               -i "${WORKDIR}"/zlib-1.2.3/{Makefile,Makefile.in}
-       einfo "zlib Makefile edited"
-
-       cd "${WORKDIR}"
-       tar czp zlib-1.2.3 -f zlib-1.2.3.tar.gz
-       tar czp grub-0.97 -f grub-0.97.tar.gz
-       tar czp lwip -f lwip-1.3.0.tar.gz
-       tar czp newlib-1.16.0 -f newlib-1.16.0.tar.gz
-       tar czp polarssl-1.1.4 -f polarssl-1.1.4-gpl.tgz
-       mv $set "${S}"/stubdom/
-       einfo "tarballs moved to source"
-}
-
-src_prepare() {
-       # Upstream's patchset
-       if [[ -n ${UPSTREAM_VER} ]]; then
-               einfo "Try to apply Xen Upstream patch set"
-               EPATCH_SUFFIX="patch" \
-               EPATCH_FORCE="yes" \
-               EPATCH_OPTS="-p1" \
-                       epatch "${WORKDIR}"/patches-upstream
-       fi
-
-       # if the user *really* wants to use their own custom-cflags, let them
-       if use custom-cflags; then
-               einfo "User wants their own CFLAGS - removing defaults"
-               # try and remove all the default custom-cflags
-               find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk 
-exec sed \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 
's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 
's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
-                       -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
-                       -i {} \;
-       fi
-
-       # Patch the unmergeable newlib, fix most of the leftover gcc QA issues
-       cp "${FILESDIR}"/newlib-implicits.patch stubdom || die
-
-       # Patch stubdom/Makefile to patch insource newlib & prevent internal 
downloading
-       epatch "${FILESDIR}"/${PN/-pvgrub/}-4.3-externals.patch
-
-       # fix jobserver in Makefile
-       epatch "${FILESDIR}"/${PN}-4.8-jserver.patch
-
-       #Substitute for internal downloading. pciutils copied only due to the 
only .bz2
-       cp "${DISTDIR}"/pciutils-2.2.9.tar.bz2 ./stubdom/ || die "pciutils not 
copied to stubdom"
-       retar-externals || die "re-tar procedure failed"
-
-       default
-}
-
-src_configure() {
-       local myconf="--prefix=${PREFIX}/usr \
-               --libdir=${PREFIX}/usr/$(get_libdir) \
-               --libexecdir=${PREFIX}/usr/libexec \
-               --disable-werror \
-               --disable-xen"
-
-       econf ${myconf}
-}
-
-src_compile() {
-       use custom-cflags || unset CFLAGS
-       if test-flag-CC -fno-strict-overflow; then
-               append-flags -fno-strict-overflow
-       fi
-
-       emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" -C 
tools/include
-
-       if use x86; then
-               emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
-               XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
-       elif use amd64; then
-               emake CC="$(tc-getCC)" LD="$(tc-getLD)" AR="$(tc-getAR)" \
-               XEN_TARGET_ARCH="x86_64" -C stubdom pv-grub
-               if has_multilib_profile; then
-                       multilib_toolchain_setup x86
-                       emake CC="$(tc-getCC)" AR="$(tc-getAR)" \
-                       XEN_TARGET_ARCH="x86_32" -C stubdom pv-grub
-               fi
-       fi
-}
-
-src_install() {
-       if use x86; then
-               emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C stubdom 
install-grub
-       fi
-       if use amd64; then
-               emake XEN_TARGET_ARCH="x86_64" DESTDIR="${D}" -C stubdom 
install-grub
-               if has_multilib_profile; then
-                       emake XEN_TARGET_ARCH="x86_32" DESTDIR="${D}" -C 
stubdom install-grub
-               fi
-       fi
-}
-
-pkg_postinst() {
-       elog "Official Xen Guide and the offical wiki page:"
-       elog "https://wiki.gentoo.org/wiki/Xen";
-       elog "https://wiki.xen.org/wiki/Main_Page";
-}

Reply via email to