commit:     5f4b7108516b4b9b90843d817dd84fb994dc1de1
Author:     Matthew Thode <prometheanfire <AT> gentoo <DOT> org>
AuthorDate: Fri Apr 13 16:06:43 2018 +0000
Commit:     Matt Thode <prometheanfire <AT> gentoo <DOT> org>
CommitDate: Fri Apr 13 16:07:01 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f4b7108

media-sound/spotify: 1.0.77 bup for amd64

fails to start if openvpn is started...

Package-Manager: Portage-2.3.27, Repoman-2.3.9

 media-sound/spotify/Manifest              |   1 +
 media-sound/spotify/spotify-1.0.77.ebuild | 124 ++++++++++++++++++++++++++++++
 2 files changed, 125 insertions(+)

diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
index e3eaa679e50..d8e0bf2a014 100644
--- a/media-sound/spotify/Manifest
+++ b/media-sound/spotify/Manifest
@@ -1,2 +1,3 @@
 DIST spotify-client_1.0.72.117.g6bd7cc73-35_amd64.deb 90872908 BLAKE2B 
9eb06a175c8321effc4404c0a2abc978bed4e4f7654d907b4e8232249b5d07e70f54a39fd1ec7cc4e14f1348d1a71ca6abf3622992063e2402d2100f227c627a
 SHA512 
fd33a5cd86edd4bf759849669516ffce35d89a77c6fcfb3ed0eb0ecb69024de5011499f36e48b8d37a873eb47da89eb21d9b9c7d280c498830a9fb1f8785db60
 DIST spotify-client_1.0.72.117.g6bd7cc73-35_i386.deb 95135550 BLAKE2B 
ad4587dd6b3c64a0398e0790203a7826e290a27542fa39ebbd6c7198d8ad1fd3fb06e8b030b64e1e61e0624ef20aafda08189266486cd073cb779ebff62ef502
 SHA512 
51d60f7592e5f31ea4b7e67736a85271cb48d4108459630da61c4ab67d2a470038240c1d6ff577280cb4498cf44f14d7bc7e0312f63d34265bcd1e70cd13142f
+DIST spotify-client_1.0.77.338.g758ebd78-41_amd64.deb 96717978 BLAKE2B 
91a4e8099076e7ccb9f44e67f2ba4ee2899ef6c5c818093a62fafd7e31e84b3bd6f44aa1439d4c0c9b8818be89c6898067ca1694946bf92da19fd92ecde6d2e7
 SHA512 
c0c08d4f6af8ffef3d9784e176c6112975ce56c7eec961df11821f4ac52785dc090e794c25874fce004da5f3e42979402e921ef12fbe1cfc80f02034448724db

diff --git a/media-sound/spotify/spotify-1.0.77.ebuild 
b/media-sound/spotify/spotify-1.0.77.ebuild
new file mode 100644
index 00000000000..fa087524e94
--- /dev/null
+++ b/media-sound/spotify/spotify-1.0.77.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils xdg-utils gnome2-utils pax-utils unpacker
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/";
+SRC_BASE="http://repository.spotify.com/pool/non-free/s/${PN}-client/";
+BUILD_ID_AMD64="338.g758ebd78-41"
+#BUILD_ID_X86=""
+#SRC_URI="amd64? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb )
+#      x86? ( ${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_X86}_i386.deb )"
+SRC_URI="${SRC_BASE}${PN}-client_${PV}.${BUILD_ID_AMD64}_amd64.deb"
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libnotify systray pax_kernel pulseaudio"
+RESTRICT="mirror strip"
+
+DEPEND=">=dev-util/patchelf-0.9_p20180129"
+# zenety needed for filepicker
+RDEPEND="
+       dev-libs/openssl:0
+       dev-libs/nss
+       gnome-base/gconf
+       gnome-extra/zenity
+       media-libs/alsa-lib
+       media-libs/harfbuzz
+       media-libs/fontconfig
+       media-libs/mesa
+       net-misc/curl[ssl,threads]
+       net-print/cups[ssl]
+       x11-libs/gtk+:2
+       x11-libs/libXScrnSaver
+       x11-libs/libXtst
+       dev-python/pygobject:3
+       dev-python/dbus-python
+       libnotify? ( x11-libs/libnotify )
+       pulseaudio? ( media-sound/pulseaudio )
+       systray? ( gnome-extra/gnome-integration-spotify )"
+       #sys-libs/glibc
+
+S=${WORKDIR}/
+
+QA_PREBUILT="opt/spotify/spotify-client/spotify"
+
+src_prepare() {
+       # Fix desktop entry to launch spotify-dbus.py for systray integration
+       if use systray ; then
+               sed -i \
+                       -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+                       usr/share/spotify/spotify.desktop || die "sed failed"
+       fi
+       default
+
+       # Spotify links against libcurl-gnutls.so.4, which does not exist in 
Gentoo.
+       patchelf --replace-needed libcurl-gnutls.so.4 libcurl.so.4 
usr/bin/spotify \
+               || die "failed to patch libcurl library dependency"
+}
+
+src_install() {
+       dodoc usr/share/doc/spotify-client/changelog.gz
+
+       SPOTIFY_PKG_HOME=usr/share/spotify
+       insinto /usr/share/pixmaps
+       doins ${SPOTIFY_PKG_HOME}/icons/*.png
+
+       # install in /opt/spotify
+       SPOTIFY_HOME=/opt/spotify/spotify-client
+       insinto ${SPOTIFY_HOME}
+       doins -r ${SPOTIFY_PKG_HOME}/*
+       fperms +x ${SPOTIFY_HOME}/spotify
+
+       dodir /usr/bin
+       cat <<-EOF >"${D}"/usr/bin/spotify || die
+               #! /bin/sh
+               exec ${SPOTIFY_HOME}/spotify "\$@"
+       EOF
+       fperms +x /usr/bin/spotify
+
+       local size
+       for size in 16 22 24 32 48 64 128 256 512; do
+               newicon -s ${size} 
"${S}${SPOTIFY_PKG_HOME}/icons/spotify-linux-${size}.png" \
+                       "spotify-client.png"
+       done
+       domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+       if use pax_kernel; then
+               #create the headers, reset them to default, then paxmark -m them
+               pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to 
run"
+               eqawarn "${PN} under a PaX enabled kernel.  To do so, we must 
modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to 
breakage!  If"
+               eqawarn "you suspect that ${PN} is being broken by this 
modification,"
+               eqawarn "please open a bug."
+       fi
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+
+       ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+       ewarn "To remove the cache:"
+       ewarn "rm -rf ~/.cache/spotify"
+       ewarn
+       ewarn "If you use KDE and are upgrading from 0.9 to 1.0, you might 
still see the old icon."
+       ewarn "Run"
+       ewarn "$ rm /var/tmp/kdecache-\$USER/icon-cache.kcache"
+       ewarn "Then log out and log in back to KDE."
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+       xdg_mimeinfo_database_update
+       xdg_desktop_database_update
+}

Reply via email to