commit:     989a661ac8ac58c2cb07b035047ca2b169064ff3
Author:     Michał Górny <mgorny <AT> gentoo <DOT> org>
AuthorDate: Sun Apr 15 09:25:39 2018 +0000
Commit:     Michał Górny <mgorny <AT> gentoo <DOT> org>
CommitDate: Sun Apr 15 09:31:34 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=989a661a

profiles: Move unkeyworded dep masks to arch/arm

Move package USE flag masks related to unkeyworded dependencies
from default/linux/arm to arch/arm where they belong.  This may fix
the issues in Hardened profiles.

 profiles/arch/arm/package.use.mask          |  6 ++++++
 profiles/default/linux/arm/package.use.mask | 14 +-------------
 2 files changed, 7 insertions(+), 13 deletions(-)

diff --git a/profiles/arch/arm/package.use.mask 
b/profiles/arch/arm/package.use.mask
index e06cdda58c2..738bca79d0d 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,12 @@
 # Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+# Michał Górny <mgo...@gentoo.org> (15 Apr 2018)
+# Unkeyworded dep masks moved from default/linux.
+app-admin/diamond mongo
+net-libs/gnutls test-full
+mail-client/mutt notmuch
+
 # Andreas Sturmlechner <ast...@gentoo.org> (02 Mar 2018)
 # Requires unkeyworded deps
 >=dev-python/ipython-5.4.1 notebook qt5 smp

diff --git a/profiles/default/linux/arm/package.use.mask 
b/profiles/default/linux/arm/package.use.mask
index d56d8e14fde..8ffe4ce9757 100644
--- a/profiles/default/linux/arm/package.use.mask
+++ b/profiles/default/linux/arm/package.use.mask
@@ -1,18 +1,6 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-# Fabian Groffen <grob...@gentoo.org> (17 Sep 2017)
-# needs dev-db/mongodb (unkeyworded)
-app-admin/diamond mongo
-
-# Alon Bar-Lev <alo...@gentoo.org> (01 Jan 2017)
-# unkeyworded
-net-libs/gnutls test-full
-
-# Fabian Groffen <grob...@gentoo.org> (07 Dec 2016)
-# unkeyworded notmuch dependency, bug #587560
-mail-client/mutt notmuch
-
 # Mike Frysinger <vap...@gentoo.org> (08 May 2016)
 # This target supports VTV #547040.
 >=sys-devel/gcc-6 -vtv

Reply via email to