commit:     266031fd39f6cc00414ffe2b019f4cfc6187539f
Author:     Ulrich Müller <ulm <AT> gentoo <DOT> org>
AuthorDate: Sun Apr 15 16:59:26 2018 +0000
Commit:     Ulrich Müller <ulm <AT> gentoo <DOT> org>
CommitDate: Sun Apr 15 17:10:37 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=266031fd

app-editors/emacs-vcs: Upstream change of version number.

Temporarily block against app-editors/emacs-26.1* because the emacs-26
branch currently has version number 26.1 too.

Package-Manager: Portage-2.3.28, Repoman-2.3.9

 .../{emacs-vcs-26.0.9999-r1.ebuild => emacs-vcs-26.1.9999.ebuild}      | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild 
b/app-editors/emacs-vcs/emacs-vcs-26.1.9999.ebuild
similarity index 99%
rename from app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
rename to app-editors/emacs-vcs/emacs-vcs-26.1.9999.ebuild
index 5748a6ed4a4..f06a4e3f3cf 100644
--- a/app-editors/emacs-vcs/emacs-vcs-26.0.9999-r1.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-26.1.9999.ebuild
@@ -118,6 +118,9 @@ DEPEND="${RDEPEND}
 if [[ ${PV##*.} = 9999 ]]; then
        DEPEND="${DEPEND}
        sys-apps/texinfo"
+
+       RDEPEND="${RDEPEND}
+       !=app-editors/emacs-${PV%.*}*"
 fi
 
 EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"

Reply via email to