commit:     cab46badda1d056395e99f342a1a4478bb46562e
Author:     Arfrever Frehtes Taifersar Arahesis <Arfrever <AT> Apache <DOT> Org>
AuthorDate: Mon Apr 16 16:17:41 2018 +0000
Commit:     Mike Gilbert <floppym <AT> gentoo <DOT> org>
CommitDate: Mon Apr 16 18:27:28 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=cab46bad

app-i18n/scim: Delete old version (1.4.14).

 app-i18n/scim/Manifest           |   1 -
 app-i18n/scim/scim-1.4.14.ebuild | 112 ---------------------------------------
 2 files changed, 113 deletions(-)

diff --git a/app-i18n/scim/Manifest b/app-i18n/scim/Manifest
index 4a8d1a6e784..13684813add 100644
--- a/app-i18n/scim/Manifest
+++ b/app-i18n/scim/Manifest
@@ -1,3 +1,2 @@
-DIST scim-1.4.14.tar.gz 1519287 BLAKE2B 
6bd2f7328e9a75c392b0f8d1d096b09b55dc88489e4524213743a9be61b29b2d610d20394d59aa83001d17d7a210e30627ab06148a4677b02344a2872608babd
 SHA512 
00fe7a1b40b69aae123c0a1e67eb3744ad1e6b1e66726bb011a7426bd28012c52b346c62f08c7ecf0977ac3e88ee416337c9fa89b39142d5eea338d99641f5df
 DIST scim-1.4.17.tar.gz 1285383 BLAKE2B 
95b9ecb0bb25a15876df8175ee0b9392c301e3b0c554ac6ccba6b863420828ce185d3454f2fef48c03e7451f01815020290be7611b8536d8a028153af3a3fe2b
 SHA512 
a7e0696330bca6fdf929ec0565ab4af1b4d0e5f73592cf5cccf1af6412eb351cd5a5ec9a3e5b83b24d6abad89bbb38a375cbbb0fd978f2fa17f6d64b69da0e3a
 DIST scim-1.4.18.tar.gz 1288060 BLAKE2B 
c2f1ce5608423734899aa6698060245c4ee253048d04d32bf5e853b8c68255340a8d35c0ebaaa50871b07c23ee9018b6bac03b18fbd4fa4dbea0e67c32c9ae30
 SHA512 
9a6090fc1ab950905a9c54d6678ce3d2a44297d1a992a3e933b0466688638e6cf470c1682daa58a6fbb6de3216b649273faf7edff1ac0ecca1c2c77fc19108fb

diff --git a/app-i18n/scim/scim-1.4.14.ebuild b/app-i18n/scim/scim-1.4.14.ebuild
deleted file mode 100644
index ff91c1be7ca..00000000000
--- a/app-i18n/scim/scim-1.4.14.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-inherit eutils flag-o-matic multilib gnome2-utils autotools-utils qmake-utils
-
-DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) 
development platform"
-HOMEPAGE="http://www.scim-im.org/";
-SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="doc gtk3 qt4"
-
-RDEPEND="x11-libs/libX11
-       dev-libs/glib:2
-       gtk3? ( x11-libs/gtk+:3 )
-       !gtk3? ( x11-libs/gtk+:2 )
-       qt4? (
-               dev-qt/qtcore:4
-               dev-qt/qtgui:4
-       )
-       >=dev-libs/atk-1
-       >=x11-libs/pango-1
-       !app-i18n/scim-cvs"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen
-               >=app-text/docbook-xsl-stylesheets-1.73.1 )
-       dev-lang/perl
-       virtual/pkgconfig
-       >=dev-util/intltool-0.33
-       sys-devel/libtool"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DOCS=(
-       README
-       AUTHORS
-       ChangeLog
-       docs/developers
-       docs/scim.cfg
-)
-
-src_configure() {
-       local gtk_version
-       if use gtk3; then
-               gtk_version="--with-gtk-version=3"
-       else
-               gtk_version="--with-gtk-version=2"
-       fi
-
-       # bug #83625
-       filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
-       local myeconfargs=(
-               $(use_with doc doxygen)
-               --enable-ld-version-script
-               $gtk_version
-               --disable-qt3-immodule
-               $(use_enable qt4 qt4-immodule)
-               --with-qt4-moc="$(qt4_get_bindir)/moc"
-       )
-       autotools-utils_src_configure
-}
-
-src_compile() {
-       autotools-utils_src_compile
-       use doc && emake docs
-}
-
-src_install() {
-       use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
-       autotools-utils_src_install
-
-       sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > 
"${T}/${PN}.conf" || die
-       insinto /etc/X11/xinit/xinput.d
-       doins "${T}/${PN}.conf"
-}
-
-pkg_postinst() {
-       elog
-       elog "To use SCIM with both GTK2 and XIM, you should use the following"
-       elog "in your user startup scripts such as .gnomerc or .xinitrc:"
-       elog
-       elog "LANG='your_language' scim -d"
-       elog "export XMODIFIERS=@im=SCIM"
-       elog "export GTK_IM_MODULE=\"scim\""
-       elog "export QT_IM_MODULE=\"scim\""
-       elog
-       elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any 
other"
-       elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
-       elog
-       elog "To use Chinese input methods:"
-       elog "  # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
-       elog "To use Korean input methods:"
-       elog "  # emerge app-i18n/scim-hangul"
-       elog "To use Japanese input methods:"
-       elog "  # emerge app-i18n/scim-anthy"
-       elog "To use various input methods (more than 30 languages):"
-       elog "  # emerge app-i18n/scim-m17n"
-       elog
-       elog "Please modify ${EPREFIX}/etc/scim/global and add your UTF-8 
locale to"
-       elog "/SupportedUnicodeLocales entry."
-       elog
-       ewarn
-       ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should 
remerge all SCIM modules."
-       ewarn
-
-       gnome2_query_immodules_gtk2
-}
-
-pkg_postrm() {
-       gnome2_query_immodules_gtk2
-}

Reply via email to