commit:     d008f46f41469c0d7370ca37c3360ba9c5a20202
Author:     Nikos Chantziaras <realnc <AT> gmail <DOT> com>
AuthorDate: Sun Apr 29 19:12:41 2018 +0000
Commit:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
CommitDate: Wed May 16 08:17:42 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d008f46f

games-engines/qtads-2.1.7-r1: fix build with GCC 7

Current version of QTads cannot be built with GCC 7. The next version will
fix that, but for now, we need -fpermissive.

Closes: https://bugs.gentoo.org/654356
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/8208

 games-engines/qtads/qtads-2.1.7-r1.ebuild | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/games-engines/qtads/qtads-2.1.7-r1.ebuild 
b/games-engines/qtads/qtads-2.1.7-r1.ebuild
index 521b932662c..500c1f64211 100644
--- a/games-engines/qtads/qtads-2.1.7-r1.ebuild
+++ b/games-engines/qtads/qtads-2.1.7-r1.ebuild
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit gnome2-utils qmake-utils xdg
+inherit gnome2-utils qmake-utils xdg flag-o-matic
 
 DESCRIPTION="Multimedia interpreter for TADS text adventures"
 HOMEPAGE="http://qtads.sourceforge.net";
@@ -21,6 +21,8 @@ DEPEND="media-libs/libsdl[sound]
 RDEPEND="${DEPEND}"
 
 src_configure() {
+       # bug 654356 temp fix
+       append-cxxflags -fpermissive
        eqmake5 qtads.pro -after CONFIG-=silent
 }
 

Reply via email to