commit:     a49624b336b94a83eb220ae1652fa02929461167
Author:     Manuel Rüger <mrueg <AT> gentoo <DOT> org>
AuthorDate: Mon Jun 11 09:23:10 2018 +0000
Commit:     Manuel Rüger <mrueg <AT> gentoo <DOT> org>
CommitDate: Mon Jun 11 09:23:10 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=a49624b3

dev-haskell/optparse-applicative: Version bump to 0.14.2.0

Package-Manager: Portage-2.3.40, Repoman-2.3.9

 dev-haskell/optparse-applicative/Manifest          |  1 +
 .../optparse-applicative-0.14.2.0.ebuild           | 29 ++++++++++++++++++++++
 2 files changed, 30 insertions(+)

diff --git a/dev-haskell/optparse-applicative/Manifest 
b/dev-haskell/optparse-applicative/Manifest
index 3e25ab90288..7614a620ee5 100644
--- a/dev-haskell/optparse-applicative/Manifest
+++ b/dev-haskell/optparse-applicative/Manifest
@@ -1,5 +1,6 @@
 DIST optparse-applicative-0.11.0.2.tar.gz 30425 BLAKE2B 
2bcdff429adc14240883b2bb1f54449d18ce10ae787f4575a60bf170868f71d4633ceea509f0b5ed4fc71a1d0d1fd68b07782ebf2b2a820e47a8c2fbf246c677
 SHA512 
eb10a274074dacf2a481c964f8fcb125c1ea6be7f33388c938ad310b49d959484102caeb1849e0370292286b7603f68853cf23ded634bb09cd34871eaec74caf
 DIST optparse-applicative-0.13.0.0.tar.gz 36101 BLAKE2B 
4dae014b933ee9e89cc417327763b92a94647ee7b5b31662df73cc3d7a1ae26dae2e2931cc1f5e573753ba7dbdefffc797125621650c248c12ecdc72c40a4232
 SHA512 
ef08f4b994703a35f7c50ba93017742188c612c99a6e69cf7329a42427e2862ec0b8498fa57dd1f64a225d3ed94c62815af211efead9e73adc32482e22e46ccb
+DIST optparse-applicative-0.14.2.0.tar.gz 53512 BLAKE2B 
512823fe0c10c31eb213aa68e1821918ebc4034b171c3f5b0c62ea2072c9b6e54695a3f94bc4d73dc1f19f67dfb664ccdfae7fe1cf0ab46433a618e7709401d3
 SHA512 
ad2252e4501be93ccf1fd9529790b850bdb01b8f36ac9cbb4145015d7609799c9774fd42feec9c8a8b535a9d17b60e0f80b9e75ac7c92444aa5098d2b9ccc096
 DIST optparse-applicative-0.5.2.1.tar.gz 24123 BLAKE2B 
aec5c0718ff629097b80a635077544d6f441fa653c4d71b196c4a5fe6773485c62fb94d615f56852bef024f262800316c18db3df30ed0d4b53c745125ace1c86
 SHA512 
7246fc6b6c9ec1c9a7b4f4e8850d80fe0958b9c659b2f31c455738d09b70178bb71f164198871874414e1fdf0ecf38098fdbc65f838224a6f6235f2d000f3876
 DIST optparse-applicative-0.7.0.2.tar.gz 26682 BLAKE2B 
4cca1216fc7267adb848d716e8ea5a9e895b418d9cd8410e1de6ee22f3eb909559ab404846af3cdbbb9c26503410f3c02dbf440296ba49252ca691ad144337e9
 SHA512 
94f583d7df97f2887cc4fea8d5b22261195c3f30bb9bf0aec2579d5b2d31583692835dc9df1273c544c3ef72343159ee90531450f7c498617a0595479efc5d0c
 DIST optparse-applicative-0.8.1.tar.gz 32055 BLAKE2B 
cc11e066a37e4506189c390db7b999ef1e87082d015f09c0bc922369e864d861791c9cfad543a9d891ce964dfd53625fc36d9a4d4513a7ca9973562e3fda679a
 SHA512 
bd7b8462d897439a77dffdc187dbf61e51937960e339c3bd5009b7479e84dd1ca1e40529c8ffd7d198d26542c23e38c45d91abe8e1b1d420090859f0f07574d6

diff --git 
a/dev-haskell/optparse-applicative/optparse-applicative-0.14.2.0.ebuild 
b/dev-haskell/optparse-applicative/optparse-applicative-0.14.2.0.ebuild
new file mode 100644
index 00000000000..b894f4d452f
--- /dev/null
+++ b/dev-haskell/optparse-applicative/optparse-applicative-0.14.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Utilities and combinators for parsing command line options"
+HOMEPAGE="https://github.com/pcapriotti/optparse-applicative";
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ansi-wl-pprint-0.6.6:=[profile?] 
<dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+       >=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+       >=dev-haskell/semigroups-0.10:=[profile?] 
<dev-haskell/semigroups-0.19:=[profile?]
+       >=dev-haskell/transformers-compat-0.3:=[profile?] 
<dev-haskell/transformers-compat-0.7:=[profile?]
+       >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.18.1.3
+       test? ( >=dev-haskell/quickcheck-2.8 <dev-haskell/quickcheck-2.12 )
+"

Reply via email to