commit:     7d5a59ef5ca62a2efb5b89626638b3a052df16fb
Author:     Michael Mair-Keimberger <m.mairkeimberger <AT> gmail <DOT> com>
AuthorDate: Sun Jul  8 09:14:42 2018 +0000
Commit:     Tony Vroon <chainsaw <AT> gentoo <DOT> org>
CommitDate: Wed Jul 11 11:30:04 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7d5a59ef

dev-ruby/gherkin: remove unused patch(es)

Closes: https://github.com/gentoo/gentoo/pull/9130

 dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch | 44 ----------------------
 1 file changed, 44 deletions(-)

diff --git a/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch 
b/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
deleted file mode 100644
index f767b1f1a2e..00000000000
--- a/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-commit 021309d273960bb5625f8072b8366eab7d077d25
-Author: C├ędric Boutillier <bou...@debian.org>
-Date:   Fri Apr 25 13:34:41 2014 +0200
-
-    change regexp matchin Ruby versions to support Ruby2.1
-
-diff --git a/lib/gherkin/formatter/pretty_formatter.rb 
b/lib/gherkin/formatter/pretty_formatter.rb
-index 28c8b54..ff13c70 100644
---- a/lib/gherkin/formatter/pretty_formatter.rb
-+++ b/lib/gherkin/formatter/pretty_formatter.rb
-@@ -199,7 +199,7 @@ module Gherkin
-         end
-       end
- 
--      if(RUBY_VERSION =~ /^1\.9|2\.0/)
-+      if(RUBY_VERSION =~ /^(1\.9|2\.)/)
-         START = /#{'^'.encode('UTF-8')}/
-         TRIPLE_QUOTES = /#{'"""'.encode('UTF-8')}/
-       else
-diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
-index 7fd85b4..4be053e 100644
---- a/ragel/lexer.rb.rl.erb
-+++ b/ragel/lexer.rb.rl.erb
-@@ -165,7 +165,7 @@ module Gherkin
-         utf8_pack(rest[0..rest.index(10)||-1]).strip # 10 is \n
-       end
- 
--      if (RUBY_VERSION =~ /^1\.9|2\.0/)
-+      if (RUBY_VERSION =~ /^(1\.9|2\.)/)
-         def utf8_pack(array)
-           array.pack("c*").force_encoding("UTF-8")
-         end
-diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
-index 72333a7..0f6e3ae 100644
---- a/spec/spec_helper.rb
-+++ b/spec/spec_helper.rb
-@@ -6,6 +6,6 @@ def silence_warnings(&block)
--if RUBY_VERSION =~ /1\.9|2\.0/
-+if RUBY_VERSION =~ /^(1\.9|2\.)/
-   silence_warnings do
-     Encoding.default_external = Encoding::UTF_8
-     Encoding.default_internal = Encoding::UTF_8
-   end
- end

Reply via email to