commit:     8ae8cd3f3b504ea70bfc665f43380604b6aa2a3e
Author:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
AuthorDate: Sun Oct 28 09:19:16 2018 +0000
Commit:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
CommitDate: Sun Oct 28 09:19:16 2018 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8ae8cd3f

app-text/poppler: Drop 0.65.0, 0.66.0

Signed-off-by: Andreas Sturmlechner <asturm <AT> gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

 app-text/poppler/Manifest              |   2 -
 app-text/poppler/poppler-0.65.0.ebuild | 126 ---------------------------------
 app-text/poppler/poppler-0.66.0.ebuild | 126 ---------------------------------
 3 files changed, 254 deletions(-)

diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 22633b1c39e..22d6a972c53 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,4 +1,2 @@
 DIST poppler-0.62.0.tar.xz 1423372 BLAKE2B 
01c8745d0c1fa5b412ec92295a8784f5c1deff8b9fa709d09a3236d630f78fecc6af23fe3302964478d6356562712726db422ef51fe59a8b42e13e08370a77ac
 SHA512 
91f7eae7b05965ae97a34e658bed2a676be8a6e4d34f82148ece6eb58932632dcf9a34d50c66412f93f560ce575abf5c608ed6b1e5184604b96024801886c706
-DIST poppler-0.65.0.tar.xz 1451720 BLAKE2B 
8d8d785a2d2b9b501e2db0736e5256236eecd72e4cd4659d198db45b8a3f219e4949f6fe460bf2429cd5ea0a5ea26e1d5d5640d1e75b1443c38f43de9b17efc4
 SHA512 
4a2c31307ab703bd25e1b5ac1185a897e1c96de13daa4fc4849974f6ea6cec8066e8cd9ea061f65620c71ea56a09b2cd355c4e42e9a4eb9a674a11648e3ec977
-DIST poppler-0.66.0.tar.xz 1457420 BLAKE2B 
55e2b6046920b7212b53adde309c9a2e1c10412b1278371b51679f4d20ae0cc4bfc359cef4865fa337a6f844c87533b9dcd13e8da0e6dce1514c0e2dacb95d47
 SHA512 
cf0ce3855d7cc28021685731308bfdeca0a7a764345432242887852d67fb4119b149ab7ba692e7031e2f0e79b9982e71446efbd75bb7886450d13ea6c5035b51
 DIST poppler-0.67.0.tar.xz 1459412 BLAKE2B 
1c24908839fc9e3b3b2a1e0c014f7b6a1c6cc622157e161437ece91a86a20db0d5ae67b35783a5a4b712ab4ba0e43f141ca516fde10b5a549b9d36a98c5de25b
 SHA512 
36584c62970ae0ae7807687f9c0523560ae92ac323949be8916a0e8dc6e691633e55cdd76c6026253c337aed8a4b43a7759a3de74c9ec606654f65379fb0f206

diff --git a/app-text/poppler/poppler-0.65.0.ebuild 
b/app-text/poppler/poppler-0.65.0.ebuild
deleted file mode 100644
index b15fbe7973a..00000000000
--- a/app-text/poppler/poppler-0.65.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
-
-if [[ "${PV}" == "9999" ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git";
-       SLOT="0/9999"
-else
-       SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz";
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SLOT="0/76"   # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so 
SOVERSION
-fi
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="https://poppler.freedesktop.org/";
-
-LICENSE="GPL-2"
-IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png 
qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-COMMON_DEPEND="
-       >=media-libs/fontconfig-2.6.0
-       >=media-libs/freetype-2.3.9
-       sys-libs/zlib
-       cairo? (
-               dev-libs/glib:2
-               >=x11-libs/cairo-1.10.0
-               introspection? ( >=dev-libs/gobject-introspection-1.32.1:= )
-       )
-       curl? ( net-misc/curl )
-       jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( media-libs/openjpeg:2= )
-       lcms? ( media-libs/lcms:2 )
-       nss? ( >=dev-libs/nss-3.19:0 )
-       png? ( media-libs/libpng:0= )
-       qt5? (
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtxml:5
-       )
-       tiff? ( media-libs/tiff:0 )
-"
-DEPEND="${COMMON_DEPEND}
-       virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
-       cjk? ( >=app-text/poppler-data-0.4.7 )
-"
-
-DOCS=(AUTHORS NEWS README README-XPDF)
-
-PATCHES=(
-       "${FILESDIR}/${PN}-0.60.1-qt5-dependencies.patch"
-       "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
-       "${FILESDIR}/${PN}-0.61.0-respect-cflags.patch"
-       "${FILESDIR}/${PN}-0.62.0-openjpeg2.patch"
-       "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       # Clang doesn't grok this flag, the configure nicely tests that, but
-       # cmake just uses it, so remove it if we use clang
-       if [[ ${CC} == clang ]] ; then
-               sed -i -e 's/-fno-check-new//' 
cmake/modules/PopplerMacros.cmake || die
-       fi
-
-       if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
-               sed '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
-                       -i CMakeLists.txt || die
-       else
-               einfo "policy(SET CMP0002 OLD) - workaround can be removed"
-       fi
-
-       # we need to up the C++ version, bug #622526, #643278
-       append-cxxflags -std=c++11
-}
-
-src_configure() {
-       xdg_environment_reset
-       local mycmakeargs=(
-               -DBUILD_GTK_TESTS=OFF
-               -DBUILD_QT5_TESTS=OFF
-               -DBUILD_CPP_TESTS=OFF
-               -DENABLE_SPLASH=ON
-               -DENABLE_ZLIB=ON
-               -DENABLE_ZLIB_UNCOMPRESS=OFF
-               -DENABLE_XPDF_HEADERS=ON
-               -DSPLASH_CMYK=OFF
-               -DUSE_FIXEDPOINT=OFF
-               -DUSE_FLOAT=OFF
-               -DWITH_Cairo=$(usex cairo)
-               -DENABLE_LIBCURL=$(usex curl)
-               -DENABLE_CPP=$(usex cxx)
-               -DWITH_GObjectIntrospection=$(usex introspection)
-               -DWITH_JPEG=$(usex jpeg)
-               -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-               -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
-               -DENABLE_CMS=$(usex lcms lcms2 none)
-               -DWITH_NSS3=$(usex nss)
-               -DWITH_PNG=$(usex png)
-               $(cmake-utils_use_find_package qt5 Qt5Core)
-               -DWITH_TIFF=$(usex tiff)
-               -DENABLE_UTILS=$(usex utils)
-       )
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # live version doesn't provide html documentation
-       if use cairo && use doc && [[ ${PV} != 9999 ]]; then
-               # For now install gtk-doc there
-               insinto /usr/share/gtk-doc/html/poppler
-               doins -r "${S}"/glib/reference/html/*
-       fi
-}

diff --git a/app-text/poppler/poppler-0.66.0.ebuild 
b/app-text/poppler/poppler-0.66.0.ebuild
deleted file mode 100644
index 893cc9f7e68..00000000000
--- a/app-text/poppler/poppler-0.66.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
-
-if [[ "${PV}" == "9999" ]] ; then
-       inherit git-r3
-       EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git";
-       SLOT="0/9999"
-else
-       SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz";
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 
~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos 
~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-       SLOT="0/77"   # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so 
SOVERSION
-fi
-
-DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
-HOMEPAGE="https://poppler.freedesktop.org/";
-
-LICENSE="GPL-2"
-IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png 
qt5 tiff +utils"
-
-# No test data provided
-RESTRICT="test"
-
-COMMON_DEPEND="
-       >=media-libs/fontconfig-2.6.0
-       >=media-libs/freetype-2.3.9
-       sys-libs/zlib
-       cairo? (
-               dev-libs/glib:2
-               >=x11-libs/cairo-1.10.0
-               introspection? ( >=dev-libs/gobject-introspection-1.32.1:= )
-       )
-       curl? ( net-misc/curl )
-       jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( media-libs/openjpeg:2= )
-       lcms? ( media-libs/lcms:2 )
-       nss? ( >=dev-libs/nss-3.19:0 )
-       png? ( media-libs/libpng:0= )
-       qt5? (
-               dev-qt/qtcore:5
-               dev-qt/qtgui:5
-               dev-qt/qtxml:5
-       )
-       tiff? ( media-libs/tiff:0 )
-"
-DEPEND="${COMMON_DEPEND}
-       virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
-       cjk? ( >=app-text/poppler-data-0.4.7 )
-"
-
-DOCS=(AUTHORS NEWS README README-XPDF)
-
-PATCHES=(
-       "${FILESDIR}/${PN}-0.60.1-qt5-dependencies.patch"
-       "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
-       "${FILESDIR}/${PN}-0.61.0-respect-cflags.patch"
-       "${FILESDIR}/${PN}-0.62.0-openjpeg2.patch"
-       "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       # Clang doesn't grok this flag, the configure nicely tests that, but
-       # cmake just uses it, so remove it if we use clang
-       if [[ ${CC} == clang ]] ; then
-               sed -i -e 's/-fno-check-new//' 
cmake/modules/PopplerMacros.cmake || die
-       fi
-
-       if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
-               sed '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
-                       -i CMakeLists.txt || die
-       else
-               einfo "policy(SET CMP0002 OLD) - workaround can be removed"
-       fi
-
-       # we need to up the C++ version, bug #622526, #643278
-       append-cxxflags -std=c++11
-}
-
-src_configure() {
-       xdg_environment_reset
-       local mycmakeargs=(
-               -DBUILD_GTK_TESTS=OFF
-               -DBUILD_QT5_TESTS=OFF
-               -DBUILD_CPP_TESTS=OFF
-               -DENABLE_SPLASH=ON
-               -DENABLE_ZLIB=ON
-               -DENABLE_ZLIB_UNCOMPRESS=OFF
-               -DENABLE_XPDF_HEADERS=ON
-               -DSPLASH_CMYK=OFF
-               -DUSE_FIXEDPOINT=OFF
-               -DUSE_FLOAT=OFF
-               -DWITH_Cairo=$(usex cairo)
-               -DENABLE_LIBCURL=$(usex curl)
-               -DENABLE_CPP=$(usex cxx)
-               -DWITH_JPEG=$(usex jpeg)
-               -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-               -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
-               -DENABLE_CMS=$(usex lcms lcms2 none)
-               -DWITH_NSS3=$(usex nss)
-               -DWITH_PNG=$(usex png)
-               $(cmake-utils_use_find_package qt5 Qt5Core)
-               -DWITH_TIFF=$(usex tiff)
-               -DENABLE_UTILS=$(usex utils)
-       )
-       use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex 
introspection) )
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       # live version doesn't provide html documentation
-       if use cairo && use doc && [[ ${PV} != 9999 ]]; then
-               # For now install gtk-doc there
-               insinto /usr/share/gtk-doc/html/poppler
-               doins -r "${S}"/glib/reference/html/*
-       fi
-}

Reply via email to