commit:     c3e33b90476849d7f3d6f0a78282600627c1da52
Author:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
AuthorDate: Tue Jan 14 22:54:54 2020 +0000
Commit:     Andreas Sturmlechner <asturm <AT> gentoo <DOT> org>
CommitDate: Tue Jan 14 22:54:54 2020 +0000
URL:        https://gitweb.gentoo.org/proj/qt.git/commit/?id=c3e33b90

dev-qt/qtwebkit: Add ruby27 to 5.212 stable branch

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm <AT> gentoo.org>

 dev-qt/qtwebkit/qtwebkit-5.212.9999.ebuild | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/dev-qt/qtwebkit/qtwebkit-5.212.9999.ebuild 
b/dev-qt/qtwebkit/qtwebkit-5.212.9999.ebuild
index 4ceacc90..334ad5b4 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.212.9999.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.212.9999.ebuild
@@ -14,7 +14,7 @@ else
        S="${WORKDIR}/${MY_P}"
 fi
 PYTHON_COMPAT=( python2_7 )
-USE_RUBY="ruby25 ruby26"
+USE_RUBY="ruby25 ruby26 ruby27"
 inherit check-reqs cmake flag-o-matic python-any-r1 qmake-utils ruby-single 
toolchain-funcs
 
 DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
@@ -124,7 +124,9 @@ src_configure() {
                -DENABLE_X11_TARGET=$(usex X)
        )
 
-       if has_version "virtual/rubygems[ruby_targets_ruby26]"; then
+       if has_version "virtual/rubygems[ruby_targets_ruby27]"; then
+               mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby27) )
+       elif has_version "virtual/rubygems[ruby_targets_ruby26]"; then
                mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby26) )
        else
                mycmakeargs+=( -DRUBY_EXECUTABLE=$(type -P ruby25) )

Reply via email to