commit:     19646d9a7d08255cf2f3733b8097475f8b37534a
Author:     Marek Szuba <marecki <AT> gentoo <DOT> org>
AuthorDate: Wed Jul  1 08:12:51 2020 +0000
Commit:     Marek Szuba <marecki <AT> gentoo <DOT> org>
CommitDate: Wed Jul  1 08:16:59 2020 +0000
URL:        https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=19646d9a

dev-python/vdf-3.3: support python3_9

Turns out using or importing the ABCs from 'collections' instead of from
'collections.abc' will only stop working in python 3.10 rather than 3.9,
therefore in the end vdf tests all pass on 3.9 without any patching.

Signed-off-by: Marek Szuba <marecki <AT> gentoo.org>

 dev-python/vdf/vdf-3.3.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/dev-python/vdf/vdf-3.3.ebuild b/dev-python/vdf/vdf-3.3.ebuild
index 2c3eaf316de..57390281171 100644
--- a/dev-python/vdf/vdf-3.3.ebuild
+++ b/dev-python/vdf/vdf-3.3.ebuild
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
 
 inherit distutils-r1
 

Reply via email to