Question here - I made the link to the 2005.0 profile on (NOT 2005.0/2.4) a system that is 2.6.11 and has been on 2.6 for months. Tonight emerge -uD system -p wants to "upgrade" me to a 2.4 kernel!!! Well, portage this is a 2.6.x system - not 2.4 - duh! From what I found in the mail list archives and forums noone has really given a solution. Some say "what problem", others give reasons for it but the fact remains - why on a 2.6 system that has happily been running 2.6 for months does this new profile want to give me a 2.4 kernel. I did follow one suggest and symlink to default-linux/x86 directory but I'm afraid that will break something so I went back to 2004.0 for the symlink. And I am at portage so that's good.

In short - what do we have to do to upgrade to a current profile on 2.6 machines and get 2.6 gentoo-source updates, not 2.4.


On Fri, 8 Apr 2005, David Sparks wrote:

Mike Frysinger wrote:
On Friday 08 April 2005 07:57 pm, David Sparks wrote:

!!! ARCH is not set... Are you missing the /etc/make.profile symlink?
!!! Is the symlink correct? Is your portage tree complete?

so use 'default-x86-2004.2', emerge portage, and then switch to the cascading

Thanks for the suggestions, I've tried 2004.0 .1 .2 .3 with similar results as below.

I also tried coping a binary package into /usr/portage/packages/... and
emerging it with the -K option but that didn't go either.

# rm make.profile # ln -s ../usr/portage/profiles/default-linux/x86/2004.2 make.profile # emerge portage

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:

To upgrade do the following steps:
# emerge -n '>=sys-apps/portage-2.0.51'
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default-linux/x86/2005.0 make.profile

# Gentoo has switched to 2.6 as the defaults for headers/kernels.  If
you wish
# to use 2.4 headers/kernels, then you should do the following to upgrade:
# emerge -n '>=sys-apps/portage-2.0.51'
# cd /etc/
# rm make.profile
# ln -s ../usr/portage/profiles/default-linux/x86/2005.0/2.4 make.profile

# More information can be found at the following URLs:

!!! 'str' object has no attribute 'insert' !!! 'rm -Rf /usr/portage/profiles; emerge sync' may fix this. If it does !!! not then please report this to and, if possible, a dev !!! on #gentoo ( -- mailing list


Brett I. Holcomb
Registered Linux User #188143
Remove R777 to email
-- mailing list

Reply via email to