On Sun, 04 Sep 2005 20:48:52 +0100 Stuart Herbert <[EMAIL PROTECTED]> wrote: | Introduce a new arch keyword "maint", to turn the concept of the | "maintainer arch" from an intangible into something real. Package | maintainers can then mark packages "~maint" or "maint" as required, | and leave the real arch keywords for the arch teams to handle. This | approach ensures that arch maintainers have the metadata they need to | know which packages the package maintainers consider appropriate for | stabilising, and which ones they don't. Any guesswork is removed.
Workable for a certain category of packages so long as it's advisory only. Arch teams need to be allowed to override maintainers where appropriate, and in some places (eg toolchain, kernel) the concept of maintainer arch is utterly irrelevant. And "maint" as a name? Yick. "maintainer" or "owner" maybe. -- Ciaran McCreesh : Gentoo Developer (Vim, Shell tools, Fluxbox, Cron) Mail : ciaranm at gentoo.org Web : http://dev.gentoo.org/~ciaranm
pgpBodFouSyIH.pgp
Description: PGP signature
