On 20-12-2008 05:35:25 +0000, Steve Long wrote:
> I note that bash-3.2_p17-r1 is stable on all the architectures that 3.0-r12
> lists (it just adds the two -fbsd archs as unstable.) portage-2.1.4.5
> requires at least that version (only unstable on mips as against 2.1.1-r2)
> It might be worth skipping to 3.2, since that would simplify regex handling.

The only problem we have there is that bash-3.2.17 only comes in patches
on top of 3.2.  During bootstrap that's problematic, as gnu patch (or
any other patch) might not be available, or simply b0rked.
For that reason we bootstrap with a portage pre SVN revision 10460,
which does not require >=3.2.17.
See http://bugs.gentoo.org/show_bug.cgi?id=229677#c11 on why PMS should
require 3.2.17 over plain 3.2 if you decide to push the requirement
update.

We can work around it by using a self-made pre-patched tarball, though.


-- 
Fabian Groffen
Gentoo on a different level

Reply via email to