Hi!

В Вск, 03/10/2010 в 13:41 +0200, Ole Markus With пишет:         
>         for slot in `php_get_slots`; do

It's better use $() instead of backticks:
http://mywiki.wooledge.org/BashFAQ/082

> [[ -z "${PHP_EXT_ZENDEXT}" ]] && PHP_EXT_ZENDEXT="no"
> 
...
> [[ -z "$USE_PHP" ]] && USE_PHP="php5-2 php5-3"

In some places eclass uses ${var} syntax but here and later it uses
$var. I'm not sure which syntax is better but in Gentoo we use ${var}
and for readability it's better to stick to single style.

> php_get_slots() {
>         local s
>         local slot

single $(local s slot) is enough here.

> php_init_slot_env() {
...
>         S="${WORKDIR}/$1"
>         cd $S

S is unquoted, and ${}

> php-ext-source-r2_buildinilist() {
...
>         for x in ${PHPSAPILIST} ; do

local x?

-- 
Peter.


Reply via email to