Tomáš Chvátal posted on Sun, 28 Aug 2011 13:28:26 +0200 as excerpted:

> I updated the grub2 ebuilds in main tree and took maintainership of
> grub2.

Thanks.

I've been wondering about trying grub2, but have some questions.

What is needed to compile it?  Specifically, my main machine is ~amd64
no-multilib and runs grub-static for grub1 (0.97-r10)  Should 64-bit gcc 
without multilib be able to compile grub2, or is 32-bit gcc needed?

If 32-bit is needed, I should be able to build it in my 32-bit netbook 
build-image chroot, but obviously I don't want it trying to do anything 
funny like trying to load into boot records, from there.

The grub-static-0.97-rX tarball is simply a binpkged grub-0.97-rX built 
and binpkged on a 32-bit machine, with an ebuild that extracts and 
installs the binaries from the binpkg.  Could the same technique be used 
for grub-static-2?

Slotted is good, as on my main machine I run a quad-disk md/RAID set, 
normally all four in RAID-1, but for /boot, only two in RAID-1, with a 
second RAID-1 for the other two, with the idea of experimenting with 
grub-2 there and selecting which to boot from the BIOS.  BTW, does grub-
static slot nicely with it as well?

Of course, for this to work, I'll presumably have to install the binpkg 
built in the 32-bit chroot slotted with grub-static on my main machine, 
then manually install to the second /boot after mounting it, and manually 
install to those disks boot records.

grub2 supports gpt I'm told.  I'm 100% gpt on both systems (main and 
netbook) and my bootable thumbdrives as well, all using grub-static at 
this point, but both systems are still conventional BIOS.  All bootable 
drives have both a legacy BIOS boot partition (1024 KB) and an EFI system 
reserved partition (127 MB, thus 128 MB for the two of them combined), 
both empty/reserved at this point, in addition to the normal md/RAID-1 
/boot partition.  Again, they're all GPT but BIOS booting.  Where's the 
optimal place to install grub2 in this setup and how do I tell it to do 
so, and/or tell the ebuild to not try to install to any boot records when 
I'm simply building/installing it in the 32-bit netbook build-image 
chroot?

Some of this might be in your devspace docs already, but I doubt it all 
is.  I could probably help with them as the answers are worked out.

I'm still posting this to the (devel, not announce) list as I imagine 
others will find your answers at global level useful as well and getting 
some discussion into the public list archives is likely to be useful, 
given the dearth of info I've seen on grub2 in Gentoo so far. However, 
taking it to bugs or to private mail will probably be better at some 
point.

-- 
Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman


Reply via email to