On 03/23/2013 04:53 PM, hasufell wrote:
> After packaging the complete humble bundle last time I noticed a bit
> of code duplication.
> Nothing serious, but I still think there could be a small eclass
> making things easier.
> 
> Especially the "remove_bundled_libs" function and the is useful IMO
> and allows to easily remove those things.
> The GAMES_PRESERVE_BUNDLED_LIBS array would allow to preserve libs,
> e.g. stuff like "libbass" which is not present in the tree and even
> GAMES_PRESERVE_BUNDLED_LIBS_amd64 (in case we have a 32bit only game
> and there are no multilib versions for some of those libs).
> 
> It also works well with a "bundled-libs" useflag (see
> games-bin_src_prepare), because it can happen that binary games break
> while the tree is moving forward with library versions, or that system
> libraries create weird blockers for the user or even cause runtime
> breakage (which happened with the editor of games-rpg/grimrock wrt
> #454934).
> 
> Most bin games use some functions from unpacker.eclass, so it is
> inherited and used in games-bin_src_unpack by default.
> 
> I was also thinking about some check-reqs thing, but it's probably
> better that is handled explicitly.
> 
> 
> If you have suggestions or if you think that approach sucks, please
> tell me.
> 

If it works, I see no reason not to commit it. It has my okay.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to