# Copyright 2014 Gentoo Foundation # Distributed under the terms of the GNU General Public License v2 or greater admin = administration # Rule of thumb 2: "This is a(n)... ...tool" # Maybe implies application? apache = apache_module # classes of packages that have their own categories is exactly why this is a good idea. app = application # Alias abbreviation to full tag apps = application arch = archiving archive = archiving auth = authentication backup = back-up # Can use hyphenated forms benchmark = benchmarking # Multiple aliases to the same thing benchmarks = benchmarking cdr = disk_authoring # Spaces replaced with underscores at word boundaries # Not the same as image mangling apps client = browser # client is a weird way of referring to them. I'd call the rest of them utilities cluster = clustering core = base # Because they're the same thing, pretty much. The other things are modules; why does this category even exist? cpp = c++ # Valid tags should be restricted to basic ASCII minus spaces (replaced with underscores) crypt = cryptography db = database devel = development # Lot of compilers; should get their own tag dialup = dial-up # Not STRICTLY necessary... dicts = dictionary doc = documentation domain_name_system = dns drivers = driver # plural > singular editors = editor # Make plural -> singular aliases standard where sensible. Rule of thumb 1: "This is a(n)..." # Maybe > application? emulation = emulator first-person_shooter = fps fonts = font fs = filesystem = file_system gamedev = game_development # "games" becomes ambiguous with "game" so prefer a more-clear form. gfx = graphics i18n = internationalisation # Will need to come to a consensus on the s/z spelling and make some aliases. lang = language = programming_language # Not to be confused with the i18n language support libs = libraries # Wait, should this be left plural? Should standardise this mail = email #no sense not being clear mail_server = mail_transfer_agent = mta # Also, {{mail server}} misc = miscellaneous mobilephone = mobile_phone multi-user_dungeon = mud .net = dotnet # This could go either way, but the leading period hides it in Unix which is inconvenient. news = newsreader = news_reader = feed_reader # somewhat nntp = {{newsreader usenet}} #pretty much. And inn is a server. nzb might be a separate tag peer-to-peer = p2p php5 = php # We only have >=php:5 in the tree. Is this necessary to keep separate? plugins = plugin power = power_management # acpi implies this. Also apm, for the two people who care print = printing proto = protocol radio: Tools and applications for working with streaming or FM radio #split off Ham radio to ham_radio = amateur_radio role_playing_game = rpg sci = science = scientific sec = security # LOTS more than just selinux stuff. That should get its own tag. Also gradm needs this. servers = server # plural > singular shells = shell sound = audio sys = system # Conflict with @system... What's the theme here anyhow? system_administration? television = tv terms = terminal texlive = tex = latex # dev-texlive mostly seems redundant because of the naming scheme. themes = theme # Well, I GUESS it's roughly accurate, but still a weird category. util = utility version_control = source_control = vcs # well known abbreviations can be used in place of their expansions visualization = visualisation # Commonwealth voice_over_ip = voip wifi = wireless wm = window_manager www = web # These are all things that deal with the web specifically. x = xorg = x11 # people commonly just call it X. Accommodate this incredibly common case.