>>>>> On Wed, 22 Jun 2016, Ulrich Mueller wrote: >> What sort of changes will need to be made in ebuilds? I ask so I >> have a list of packages I can draw up that need this changed so I >> can get things done when everything's in place with the guide.
> For the simple two- and three-letter language codes it will be only > renaming from linguas_* to l10n_*. I should be more accurate here: If your package uses linguas_* use conditionals for downloading additional language bundles in SRC_URI, for pulling in additional dependencies, or for anything else that isn't gettext related, then the linguas_* flags should be renamed to l10n_*. On the other hand, if the package uses LINGUAS in its functions as gettext variable, you should do nothing at this point. Especially, you should currently keep all linguas_* flags in IUSE. > [...] we can do the rest in one atomic commit, along with the > removal of LINGUAS from USE_EXPAND. Ulrich
pgph9ZaAGiem3.pgp
Description: PGP signature
