On Thu, 2019-07-18 at 17:53 +0100, Dirkjan Ochtman wrote:
> On Thu, Jul 18, 2019, 15:53 Michał Górny <[email protected]> wrote:
> 
> > Introduce 'sha' flag that corresponds to SHA-NI instruction set.
> > This has two potential users, and is present in git version
> > of cpuid2cpuflags (pending release once the flag is added).
> > 
> 
> A bit of bikeshedding: as I understand it, SHA-NI covers SHA-1 and SHA-256,
> but not SHA-3 or some of the other SHA-2 variants. Maybe name it sha-ni or
> sha_ni to be more accurate?
> 

We already name AES-NI 'aes', so naming SHA-NI 'sha' follows suit. 
Besides, unless I'm mistaken NI stands for 'new instructions',
so I don't see how that would be relevant to SHA algorithms supported.

-- 
Best regards,
Michał Górny

Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to