On Mon, Dec 16, 2019 at 10:26 AM Marek Szuba <mare...@gentoo.org> wrote: > What do you think, guys?
I don't love it. I don't like the mess that has become VIDEO_CARDS=... either. radeon vs radeonsi vs amdgpu. Different names for different bits of the stack, even for the same hardware. I would like to come up with something that avoids the confusion users often have. Does anyone have suggestions? Should we make a cpuid2cpuflags equivalent for VIDEO_CARDS? Should VIDEO_CARDS specify only the vendor with MESA_VIDEO_CARDS=... etc for individual packages? (Seems gross) Should VIDEO_CARDS be more fine grained with multiple names for the same thing sometimes? (e.g., offer VIDEO_CARDS=amdgpu for media-libs/mesa that enables the radeonsi driver; similarly offer VIDEO_CARDS=radeonsi for x11-libs/libdrm that enables libdrm_radeon). I think perhaps that in conjunction with a cpuid2cpuflags-equivalent is the most sensible.