Hey Jason,

I'd be surprised if anyone felt like having too much time at there hands to
pick this up but I come from the other side (I use libressl and sometimes
run into packages expecting openssl).
One thing I was wondering is if there is something like slot support for
virtuals that would allow most packages depending on any slot but others
on a specific slot.

Personally I don't have the knowledge to tackle a problem like this and
rather keep on patching openssl-only ebuilds to work with libressl or miss
out on packages/updates until somebody else get's to solving this.


Best,

Marcel


On Wed, Jan 29, 2020 at 10:27:04AM +0100, Jason A. Donenfeld wrote:
> Hey,
> 
> For a long time now, OpenSMTPD stopped supporting OpenSSL, only
> supporting LibreSSL. For that reason Gentoo's opensmtpd ebuild is
> stuck on the 6.0 version. I'm not happy about this.
> 
> It looks like other distros solve this by allowing libressl to install
> its libraries to /usr/lib/libressl or similar, so that they can
> coexist with openssl, allowing programs like OpenSMTPD.
> 
> Any libressl developers interested in this sort of thing?
> 
> Jason

Reply via email to