The old autoconf-2.13 version requires options to be specified
before the file name argument, so packages with WANT_AUTOCONF="2.1"
would fail to build in a sysroot with the -l option at the end.

Closes: https://bugs.gentoo.org/710792
Signed-off-by: David Michael <fedora....@gmail.com>
---
 eclass/autotools.eclass | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 9df0e1b9366..625abd0e9d1 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 # @ECLASS: autotools.eclass
@@ -512,7 +512,7 @@ autotools_run_tool() {
        fi
 
        if ${m4flags} ; then
-               set -- "${1}" $(autotools_m4dir_include) "${@:2}" 
$(autotools_m4sysdir_include)
+               set -- "${1}" $(autotools_m4dir_include) 
$(autotools_m4sysdir_include) "${@:2}"
        fi
 
        # If the caller wants to probe something, then let them do it directly.
-- 
2.21.1


Reply via email to