Arthur Zamarin posted on Sun, 16 Jun 2024 21:15:25 +0300 as excerpted:

> On 16/06/2024 18.51, Florian Schmaus wrote:
>> This new eclass includes various improvements over the existing
>> readme.gentoo-r1.eclass.
> So, some weird question from me - why is it called greadme? I can
> understand why you don't want to modify existing eclass, but why not
> call it "readme.gentoo-r2.eclass"? This should make it a little less
> confusing (cause I imagine folks asking - which to use. With -r2 we all
> know which one is better).

I had the same question but it was answered to my satisfaction in
[PATCH v3 0/1].  Quoting from that:

>>> [I]f anyone wants to have function names like
>>> 'readme.gentoo-r2_pkg_postinst', then we can go with that.

Convinced me!  greadme's /just/ fine, thankyou! =:^)

(Tho purely bikeshedding I'd prefer g2readme or gen2readme.  Which FWIW 
would match my gentoo bug shortcut g2b/g2bug...)

Duncan - List replies preferred.   No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master."  Richard Stallman

Reply via email to