I'm trying to install musl (x86) on an old laptop.  I start off with
x86 minimal install to boot an old laptop.  After partitioning and mkfs,
I...

mount /dev/sda1 /mnt/gentoo
cd /mnt/gentoo
wget stage3-i686-musl-vanilla-20180304.tar.bz2
tar xpf stage3-*.tar.{bz2,xz} --xattrs-include='*.*' --numeric-owner

The first problem is...
=======================================================
tar: Pattern matching characters used in file names
tar: Use --wildcards to enable pattern matching, or --no-wildcards to suppress 
this warning
tar: stage3-*.tar.xz: Not found in archive
tar: Exiting with failure status due to previous errors
=======================================================

OK, change the command to...
tar xpf stage3-*.tar.bz2 --xattrs-include='*.*' --numeric-owner
...and it extracts.

  I make 2 changes to make.conf...
1) add GENTOO_MIRRORS
2) add MAKEOPTS="-j2" (Laptop is a Core2 Duo with 2 cores)

  Then I chroot and
emerge --sync
echo "dev-vcs/git -gpg" >> /etc/portage/package.use
emerge -q layman dev-vcs/git

  Now the "fun" begins...

=======================================================
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by 
(net-misc/openssh-7.5_p1-r4:0/0::musl, installed)
                                  ^^^^^^^                                       
                                                            

  (dev-libs/openssl-1.0.2n:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by 
(dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2-r1::gentoo[-libressl]
# required by dev-python/pyopenssl-17.2.0::gentoo
# required by dev-python/urllib3-1.22::gentoo
# required by dev-python/requests-2.18.2-r1::gentoo
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/layman-2.4.2::gentoo
# required by layman (argument)
>=dev-libs/openssl-1.0.2n -bindist
=======================================================

  So I add the line...
>=dev-libs/openssl-1.0.2n -bindist
...to /etc/portage/package.use and run "emerge -q layman dev-vcs/git"
and get the following.  How can I resolve this?

=======================================================
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[bindist] required by 
(net-misc/openssh-7.5_p1-r4:0/0::musl, installed)
                            ^^^^^                                               
                                                            
    (and 4 more with the same problem)

  (dev-libs/openssl-1.1.0g-r2:0/1.1::gentoo, ebuild scheduled for merge) pulled 
in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by 
(dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                
                                                                    

NOTE: Use the '--verbose-conflicts' option to display parents omitted above


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2-r1::gentoo[-libressl]
# required by dev-python/requests-2.18.2-r1::gentoo[ssl]
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/layman-2.4.2::gentoo
# required by layman (argument)
=dev-libs/openssl-1.1.0g-r2 ~x86

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2-r1::gentoo[-libressl]
# required by dev-python/requests-2.18.2-r1::gentoo[ssl]
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/layman-2.4.2::gentoo
# required by layman (argument)
# /usr/portage/profiles/package.mask:
# Lars Wendler <polynomia...@gentoo.org> (26 Aug 2016)
# Masked while being tested and reverse deps aren't fully compatible
=dev-libs/openssl-1.1.0g-r2
=======================================================

  If I understand properly, it wants...
echo "=dev-libs/openssl-1.1.0g-r2 ~x86" > /etc/portage/package.accept_keywords
echo "=dev-libs/openssl-1.1.0g-r2" > /etc/portage/package.unmask

  But doing that, plus "emerge -q layman dev-vcs/git" gives me...
=======================================================
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2n:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0= required by (net-misc/openssh-7.5_p1-r4:0/0::musl, 
installed)
                    ^^^^^                                                       
                                           
    (and 4 more with the same problem)

  (dev-libs/openssl-1.1.0g-r2:0/1.1::gentoo, ebuild scheduled for merge) pulled 
in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by 
(dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)
                                                                                
                                                                    

NOTE: Use the '--verbose-conflicts' option to display parents omitted above
=======================================================

  Now what???

-- 
Walter Dnes <waltd...@waltdnes.org>

Reply via email to