René 'Necoro' Neumann yazmış:
> What's the best way to send patches for the patches ;) ?

In this particular case you shouldn't send patches for patches, so it's
not a problem, see below ;)

<snip>
> But the complete expression could be rewritten as:
> 
>     return [int(fd) for fd in os.listdir("/proc/%i/fd" % os.getpid()) if
> fd.isdigit()]
> 
> This is more readable - and you don't need to traverse the list multiple
> times.
> 
> Alternatively - if you like the functional style more:
> 
>     return list(map(int, filter(str.isdigit, os.listdir("/proc/%i/fd" %
> os.getpid()))))
> 
> Again more readable (if you are used to the functional style ;)) - and only
> one traversal (as iterators are used).
> 

Portage aims for 2.4 compatibility and your snippets should work on 2.4
afaik. So you can submit it as a patch to the current trunk.
Changing the automatically generated output is not a good idea.

> Regards,
> Necoro

-- 
Regards,
Ali Polatel

Attachment: pgpE4ozCfOnGL.pgp
Description: PGP signature

Reply via email to