On 10/27/2014 01:22 AM, Alexander Berntsen wrote:
> On 27/10/14 08:33, Zac Medico wrote:
>> +                                    if not 
>> self._depgraph._virt_deps_visible( +                                         
>>     new_child,
>> ignore_use=True): +                                          continue +      
>>                                 if pkg < new_child: +
>> return False
> Seems needlessly bit obscure when you could just "if
> self.depgraph._virt_deps_visible(new_child, ignore_use=True) and pkg <
> new_child" or some variant thereof. But it's a minor qualm.

I prefer not to group them into a single expression because they are
separate heuristics. At some point in the future, we may find that we
need to adjust one or both heuristics, add more heuristics, or remove
some heuristics. Keeping the heuristics as separate expressions makes it
easier to do such modifications. It also provides emphasis to the reader
that these are separate heuristics.

> Otherwise LGTM, go ahead & push.

Thanks, it's pushed:

https://github.com/gentoo/portage/commit/d3be49fe6827aa1974856dffe6d5a1aca80a7bed
-- 
Thanks,
Zac

Reply via email to