On 7/25/19 4:29 PM, Michał Górny wrote: >> >> * In the md5-cache entry, maybe use a common prefix like EXT_ for the >> extra keys in order to distinguish them from normal keys. > > Yeah, I was thinking of something like '__ext_foo', or '__ext[foo]'. >
What are the pros/cons of this? The names refer to global variables, so they should already be safely namespaced, right?. There is a possibility that an eclass variable name (e.g. PATCHES) could become standardized at a later date. If that happens, we could wind up with both FOO and __ext_FOO in the cache, and tools would have to figure out what to do with zero, one, or both present. (This has happened in email/web protocols when an X-Foo header was standardized.) It's not the end of the world, but someone would have to stop and think about it. Finally, just having the name be predictable so that I can grep '^FOO=' without having to care where it came from is nice. OTOH for testing, and for figuring out why these weird variables are showing up in my cache, the prefix would help.