On Wed, 2 Mar 2005, Mike Williams wrote:

> On Wednesday 02 March 2005 17:27, A. Khattri wrote:
> > Have I missed out a step along the way?
> I believe you need a DEVICE specification per array.

Yes, I have DEVICE and ARRAY lines in mdadm.conf - see the grep commands
at the end of my previous post.

I have managed to get something working but its not quite right.

I had an existing disk with a Gentoo install image on it and an empty one.
So I made a RAID array out of partitions on the empty disk (only one
partition per RAID device). I then mounted and copied files across from
the install disk into the RAID devices - this worked fine.

Now what I want to do is add the partitions on the install disk to the
arrays Ive created so that there are two partitions per RAID device. So I
ran fdisk on the install disk, marked the partitions as Linux RAID auto
and then tried to add them to the array.

Right now, I can assemble the array but the added disk is marked as a
spare instead of a mirror:

livecd dev # mdadm -A /dev/md0 /dev/sda1 /dev/sdb1
mdadm: /dev/md0 has been started with 1 drive and 1 spare.

livecd dev # cat /proc/mdstat
Personalities : [raid0] [raid1] [raid5] [raid6] [raid10]
md0 : active raid1 sda1[0] sdb1[1]
      56128 blocks [1/1] [U]

unused devices: <none>

I tried stopping the device and editing my mdadm.conf to reflect the
changes I made (see grep lines in previous post) but this doesn't work. I
think I need to do an additional step to get this working?

(Im doing it this way because I dont want to have to do a Gentoo install
all over again on the RAID drives...).

gentoo-user@gentoo.org mailing list

Reply via email to